Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1.Выполнить отладку следующей программы:

10-11 класс

A) SCREEN 9
FOR X=1 TO 640
CLS
CIRCLE(Х+I, 100),30,2
FOR J=1 T0 5000
NEXT J
CIRCLE(Х+1,100),30,0
NEXT X
Б) Изменить эту программу таким образом, чтобы окружность двигалась по экрану сверху вниз.

медведьгора2013 01 дек. 2016 г., 18:39:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
45539
01 дек. 2016 г., 21:27:02 (7 лет назад)

выполняем отладку 
SCREEN 9
FOR X = 1 TO 64
CLS
CIRCLE (Х+I,100), 30, 2 (зачем нам cдвиг на I? убираем его)
FOR J = 1 TO 5000 '
NEXT J
CIRCLE(Х+1,100),30,0    (эту строчку вообще убираем)            
NEXT X
 Получим

+ 0 -
Фaтя
01 дек. 2016 г., 22:35:28 (7 лет назад)

FOR J=1 T0 5000
NEXT J

+ 0 -
Zhanna2913
02 дек. 2016 г., 1:31:20 (7 лет назад)

FOR J=1 T0 5000
NEXT J - это я так понимаю у вас некая пауза в программе?

+ 0 -
Indianaturgenova
02 дек. 2016 г., 3:27:23 (7 лет назад)

SCREEN 9
FOR X = 1 TO 64
CLS
CIRCLE (100, X), 30, 2
FOR J = 1 TO 5000 'Для моего компа 5000 очень мало, движение не заметно я ставил 5000000, зависит от быстродействия компа
NEXT J
NEXT X

+ 0 -
КлэP
02 дек. 2016 г., 5:56:57 (7 лет назад)

спасибо ребят

Ответить

Другие вопросы из категории

Pascal.Не могу нормально вывести S которое вычисляется в процедуре. Если просто выводить переменную S то показывает 0. Как нормально вывести S? Программа

считает всё правильно, но с выводом проблемы.
program kr_pr_4;

procedure fgerona(a,b,c:real);
var
p,s:real;
begin
p:=(a+b+c)/2;
s:= sqrt(p*(p-a)*(p-b)*(p-c));

end;

var
a,b,c,s,p:real;
begin
writeln('Введите сторону А');
read(a);
writeln('Введите сторону B');
read(b);
writeln('Введите сторону C');
read(c);
fgerona(a,b,c);
writeln('S = ',s);
end.

Читайте также

Сколько циклов будет выполнено в следующей программе?

S:=0;
N:=7;
While s<>28 do
S:=S+N;

С++

Написать программу, которая переводит число из 9-й системы счисления в 3-ю, не переводя все число в 10-ю. Выполнить отладку программы с помощью какого–либо примера, подготовленного Вами на бумаге.

алгоритм Мишень цел n, k, i вещ массив P[1000] вещ r1, r2 начало ввести

n, массив P и радиусы r1, r2 /* Исходные данные */

вывести заголовок задачи и значения n, P, r1, r2 k ¬0 для i от 1 до n шаг 1 выполнять/*

Подсчитать число точек */ если r1 < ri и ri < r2 то k ¬k +1

конец-если

конец-цикл

вывести заголовки выходных данных и значений k конец

Теперь спланируем тестирование.

Проверку программы выполним при следующих исходных данных.

Зададим число точек на плоскости: n = 10. Подберем расстояния и радиусы: 0.03 21.0 12.89 7.41 99.99

P = 12.34 56.78 90.98 7.6 0.54

r1 = 12.35 r2 = 56.90.

Выходные данные в этой задаче будут иметь вид: Мишень Исходные данные:

n= 10 Массив P[n]: 0.03 21.0 12.89 7.41 99.99 12.34 56.78 90.98 7.6 0.54 r1 = 12.35 r2 = 56.90

Ответ: внутри 3 точки (три точки находятся внутри кольца).помогите написать программа в паскале и алгоритм блок-схему.пожалуйста срочно!

Определите значение переменной K после выполнения следующей программы a=-5; b=-12; c=0; d=7; k=0

если a<0 то k:=k+1
все
если b<0 то k:=K+1
все
если c≤0 то k:=k+1
все
если d<0 то k:=k+1
иначе k:=k+2
все

Помогите пожалуйста,через пару дней сдавать надо.

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] – заданий сделал первый ученик Dat[2] – второй ученик и т.д.). Определите, что будет напечатано в результате работы следующей программы.

Алгоритмический язык

алг

нач

целтаб Dat[1:12]

цел k, m , month

Dat[1]:=5; Dat[2]:=5

Dat[3]:=6; Dat[4]:=8

Dat[5]:=4; Dat[6]:=5

Dat[7]:=4; Dat[8]:=7

Dat[9]:=4; Dat[10]:=4

Dat[11]:=8

Dat[12]:=7

month := 1; m:= Dat[1]

нц для k от 2 до 12

если Dat[k] <= m то

m:=Dat[k]

все

кц

вывод month

кон



Вы находитесь на странице вопроса "1.Выполнить отладку следующей программы:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.