Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

S=1/2*a*h решить по паскале

10-11 класс

Svetkayurova 15 янв. 2014 г., 19:59:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
4246
15 янв. 2014 г., 22:40:09 (10 лет назад)

var a, h: integer;
begin
   read(a, h);
   writeln(a*h/2)
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста,

Нарисуйте диаграмму множества А, В, С и D, если:
А-множество всех листьев
В-множество дубовых листьев
С-множество кленовых листьев
D-множество жёлтых листьев.

Читайте также

помогите пожалуйста решить в паскале. Создайте двухмерный массив Х, имеющий четыре строки и три столбца, и найдите в нем максимальный по абсолютному

значению элемент, а также номера строки и столбца, содержащих этот элемент. Например, в массиве, показанном справа, максимальный по абсолютному значению элемент равен 8, он находится во 2-й строке 3-го столбца.

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Помогите решить в паскаль.

По древней легенде мудрец, который изобрел шахматы, потребовал от персидского шаха такое количество пшеницы, чтобы им можно было покрыть шахматную доску, положив на первую клетку 1 зерно, на вторую - 2, на третью - 4 и т.д., т.е. на каждую следующую в двое больше предыдущей. Каким количеством зерна можно покрыть шахматную доску?


Для вывода на экран произвольной символьной строки нужно в команде вывода записать эту строку в апострофах. Например, по команде вывод "ОТВЕТ"

на экран выведется слово ОТВЕТ.

Определите, какая задача решается по следующему алгоритму:

алг Задача-6
вещ X
нач ввод X
если Х < 0
то вывод "отрицательное число"
иначе вывод "положительное число"
кв
кон



Вы находитесь на странице вопроса "S=1/2*a*h решить по паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.