Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите составить программу изменить значение в массиве: 1)Отриц. элементов на противоположные 2)Элементы, которые больше 100 заменит 0

10-11 класс

МамашаГошана1979 01 янв. 2015 г., 18:29:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КРИС222
01 янв. 2015 г., 19:58:47 (9 лет назад)

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
    int a[15];

    srand(time(0));

    for(int i = 0; i < 15; i++)
    {
        a[i] = rand() % 401 - 200; //От - 200 до +200

        cout << a[i] << ' ';
    }
    cout << endl;

    for(int i = 0; i < 15; i++)
    {
        if(a[i] < 0)
        {
            a[i] *= -1;
        }
        else if(a[i] > 100)
        {
            a[i] = 0;
        }

        cout << a[i] << ' ';
    }
    cout << endl;

   return 0;
}

Ответить

Другие вопросы из категории

Петя любит есть вареные яйца.Для того, чтобы приготовить яйцо в смятку нужно варить его Х минут. Чтобы приготовить яйцо вкрутую, нужно сначала приготовить

его всмятку, а потом варить его У минут. Петя любит есть яйцо, когда оно наполовину приготовлено вкрутую, т.е.когда яйцо сначала приготовлено всмятку, а потом прошла еще половина времени, необходимого для того, чтобы это яйцо стало приготовленым вкрутую. Найдите, сколько минут Пете нужно варить яйцо. (1менше или равна Х, У меньше или равен 10 в восемнадцатой степени) Написать программу на Паскаль

помогите составить программу в паскале

z1= 1/4 - 1/4*sin(5/2pi-8a)
z2= (1-sin^2a)/(1+sin2a)

люди каких профессий работают с символьной, графической и звуковой информации?

Профессия и программное обеспечение.

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода

результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45



Вы находитесь на странице вопроса "помогите составить программу изменить значение в массиве: 1)Отриц. элементов на противоположные 2)Элементы, которые больше 100 заменит 0", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.