Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1. Вводиться последовательность ненулевых чисел, 0-конец последовательности. Определить среднее значение элементов последовательности

10-11 класс

знамин 11 мая 2015 г., 23:08:48 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
пугачиха
12 мая 2015 г., 1:55:49 (8 лет назад)

Program zadacha;
uses crt;
var a:array[1..10]of integer;
i,k,sum:integer;
begin
i:=0; k:=0;
repeat
inc(i);
readln (a[i]) ;

inc(k) ;
until a[i]=0;
sum:=0;
for i:=1 to k do
sum:=sum +a[i];

writeln('sr_znach ',sum/k);
end.

 

Помог отметь как лучший ответ

+ 0 -
Vikysik5
12 мая 2015 г., 3:38:54 (8 лет назад)

Проверено на Паскаль АВС

 

Program Dafnochka;
uses crt;
var
  r,sum: real;
  k:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  sum:=0;
  k:=0;
  r:=1;
  writeln('Введите ненулевое число');
  writeln('(или введите 0 для конца последовательности) ');
  while r<>0 do
    begin
      write("Ввод:") ;  
      readln (r);
      sum:=sum+r;
      k:=k+1;  
    end;
  writeln();
  writeln('Всего введено ',k-1,' чисел');
  writeln('Среднее значение равно ',sum/(k-1));
end.

Ответить

Другие вопросы из категории

Вычислить S1=11₁₆+11₈+11₂=(11)hex+(11)oct+(11)bin=(??)dec

S2=111₁₆+111₈+111₂=(111)hex+(111)oct+(111)bin=(??)dec
Помогите ,пожалуйста)))

Читайте также

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел



Вы находитесь на странице вопроса "1. Вводиться последовательность ненулевых чисел, 0-конец последовательности. Определить среднее значение элементов последовательности", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.