Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решите все задания пожалуйста очень срочно

5-9 класс

Samvel72 04 февр. 2014 г., 13:57:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vika1997bogdan
04 февр. 2014 г., 16:13:31 (10 лет назад)

1. 
var a,b,c:byte;
begin
write('Введите стороны а,в,с');
read(a,b,c);
if (a=b)or(a=c)or(b=c) then writeln('Треугольник равнобедренный') else writeln('треугольник не равнобедренный');
end.
2.
var x:shortint;
begin
write('Введи х:');
read(x);
if x<=2 then writeln('f(x)=',x*x+4*x+5) else writeln('f(x)=',1/(x*x+4*x+5));
end.
3.
var x:shortint;
begin
write('Введи х:');
read(x);
if x<=0 then writeln('f(x)=0');
if (0<x) and (x<=1) then writeln('f(x)=',x);
if x>=1 then writeln('f(x)=',x*x);
end.
4.
var x:integer;
begin
write('Введи число:');
read(x);
if ((x mod 100)=((x mod 10)div 10))or((x mod 10)div 10)=(x div 100))or((x mod 10)=(x div 10)) then writeln('Есть') else writeln('Нет');
end.
5.
var a,b,c:byte;
begin
writeln('Введите длины отрезков:');
read(a,b,c);
if (a*a=b*b+c*c) or (b*b=a*a+c*c) or (c*c=a*a+b*b) then writeln('Можно') else writeln('Нельзя');
end.
6.
var x:integer;
begin
write('Введи число:');
read(x);
if x>0 then writeln(x+1) else writeln(x-2);
end.
7.
var a,b,c:integer;
begin
write('Введи A,B и C:');
read(a,b,c);
if abs(a-c)>abs(a-b) then writeln('C на расстоянии ',abs(a-c)) else writeln('B на расстоянии ', abs(a-b));
end.

Ответить

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Помогите, пожалуйста, очень срочно

1. Чему будет равняться x после выполнения фрагмента программы:
x:=0;
repeat
x:=x+8
until x>=21.

2. Дано описание массива
var mas: array [-22;0] of integer;
Сколько элементов содержит данный массив?

3.Определите, что делает следующая программа, и какой результат она выдаст на заданном массиве (1,4,0,-1,-4)
Program n1
const n=5
var a: array [1...n] of integer;
i,b: integer;
begin
b:=a[1];
for i:=2 to n do
if a[i] writeln (b);
end.

4. Допустим, имеется одномерный массив, содержащий от 0 до 49 включительно. Требуется исключить из него все элементы, значения которых меньше 15.

Пожалуйста помогите!! очень срочно, нужно написать программу скорей всего мне кажется в паскале

1. Writel(' вести стоимость перчатки наприм')
read (x)
2 стоимость сумки- наприм.
3.стоимость ремня- наприм.
4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки
5.если сумма меньше 800р, то вывести сумму
Помогите пожалуйста очень нужно, благодарю!!!

Помогите пожалуйста,очень срочно!

Ввести три числа,вывести на экран их сумму,произведение и среднее арифметическое.

(В паскале,по такому типу:
Var
Begin
WriteLn
End)
Буду очень благодарна!



Вы находитесь на странице вопроса "Решите все задания пожалуйста очень срочно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.