Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Блин,учительница сказала еще решить одну карточку,чтобы она поставила 4 в году.Помогите пожалуйста решить вот первые номер:Сформируйте и выведите

5-9 класс

на экран массив из девяти элементов,каждые три последовательных элементов которого составлены по следующему правилу:1й равен квадрату текущего индекса,увеличенному на 5,2й равен целой части квадратного корня из предыдущего элемент,3й равен целой части от деления двух предыдущих элементов.

Крайнег 22 дек. 2014 г., 23:07:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bicaa
23 дек. 2014 г., 1:00:50 (9 лет назад)

uses crt;
var
a:array [1..9] of integer;
i,c,m,n:integer;
b:real;
begin
clrscr;
randomize();
c:=1;
for i:=1 to 9 do
begin
if i=c then
begin
a[i]:=5+sqr(i);
c:=c+3;
m:=a[i];
end
else
begin
if i mod 3=0 then
begin
b:=m/n;
b:=trunc(b);
a[i]:=round(b);
end else
begin
a[i]:=trunc(sqrt(a[i-1]));
n:=a[i];
end;
end;
write(a[i],' ');
end;
readln();
end.

Ответить

Другие вопросы из категории

В 1626 году индейцы продали остров Манхеттен за 20 долларов. Если бы эти деньги были помещены в банк на текущий счет и ежегодный прирост составлял x%,

какова была бы стоимость капитала в этом году? Надо сделать в паскаль абс.

Помогите второе решить
Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Заполнить пропуски цифрами:

_____Кбайт=______байт=2 в 13 степени бит.

Читайте также

марине яблочковой не нравилось что ее фамилию называют последней.и учительница сказала ей если ты составишь новый список я буду пользоваться им.помогите

отсортировать список чтобы ее фамилия оказалась первой.восстановите так же список учительницы. марина яблочкова
катя арбузова
валя стрелкина
роберт щукин
коля белкин
лена волкова
дима иволгин
сережа тополев
яша арбузов

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Здравствуйте.Помогите,пожалуйста,решить задачи в Паскале.Вот: Ввести с клавиатуры несколько дробных чисел, признак окончания ввода – число

1000.Нужно изменить программу так,чтобы она находила:

а) дробную часть чисел;

б) произведение чисел, меньших 22;

в) сумму чисел, которые попадают в промежуток [10, 50]. Заранее,спасибо большое!)))))

решить на Паскале или Питоне, или .хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась.

Найдите ее, зная номера оставшихся карточек. Входные данные:Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).



Вы находитесь на странице вопроса "Блин,учительница сказала еще решить одну карточку,чтобы она поставила 4 в году.Помогите пожалуйста решить вот первые номер:Сформируйте и выведите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.