Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Дан двумерный массив a, размером (n´m). Найти минимальный

10-11 класс

элемент в каждой строке матрицы среди отри­цательных элементов.

Razmik7 25 июля 2016 г., 3:46:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ramvioletta
25 июля 2016 г., 6:41:02 (7 лет назад)

program gt;
var a:array[1..100,1..100]of integer;
n,m,i,j,min:integer;
begin
read(n,m);
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
min:=a[i,1];
for j:=1 to m do
begin
if(a[i,j]<min)then min:=a[i,j];
end;
if (min<0)then writeln(min)else writeln('отрицательных чисел нет в ',i,' строке');
end;
end.

+ 0 -
Polinka90979
25 июля 2016 г., 7:35:41 (7 лет назад)

а если среди них не будет отрицательных?

+ 0 -
эах
25 июля 2016 г., 9:46:16 (7 лет назад)

должен быть

+ 0 -
Slon19100
25 июля 2016 г., 11:19:18 (7 лет назад)

ну я зделал в обшем случае

Ответить

Другие вопросы из категории

Информ. - тема Логика

Упростить следующие выражения:

1. (X v Z v Y) & (X v ¬Y v Z­­) & (X v ¬Y v ¬Z)

2. (A v ¬B) v A v F & E v B

3. X v T & Y & Z & ¬(X v T)

Тема:Рекуррентные соотношения. Помогите пожалуйста написать программу для вывода последовательности Условие: b1=5; bn=(-1)^n * bn-1

-8

минус 1 в степени n, умножить на b n-1 (n-1 ->подстрочный текст) - 8

Начинаю писать программу, а в степень без понятия как возвести

program posledovatelnost;
uses crt;
var i,n:integer; b1,bn:real;
begin clrscr;
writeln ('введите n');
readln (n);
b1:=5;
writeln ('1 элемент = ', b1);
for i:=2 to n do
begin
bn:=...
writeln (i, 'элемент = ', bn);
b1:=bn;
end;
readln
end.

что написать, чтобы считать правильно bn, нужно чтобы работало в TP, поэтому power,pow и exp бесполезны.

Книга - это документ?

Читайте также

Дан двумерный массив a размером n*n. Написать программу определения номера столбца с максимальной суммой элементов. Дан двумерный массив

а размером n*n. В каждой строке изменить значения элементов, стоящих за минимальным элементом этой строки, на 1

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

1. Задать двумерный массив (10х10) по формуле, так чтобы значения элементов совпадали с номерами столбцов в квадрате.

2. Задать двумерный массив (4х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы.
3. Задать двумерный массив (7х7) случайными значениями от 12 до 18 включительно. В каждом столбце матрицы найти количество элементов, значения которых меньше 14.
4. Задать двумерный массив (3х3) с клавиатуры, поменять значения элементов 1 столбца со вторым.
5. Найти минимальный элемент матрицы (5х5), заданной случайными значениями от 1 до 5 включительно, лежащие ниже главной диагонали.



Вы находитесь на странице вопроса "Дан двумерный массив a, размером (n´m). Найти минимальный", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.