Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1. Найти самую большую цифру целого числа.

10-11 класс

архипова11 30 мая 2013 г., 9:06:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DCH
30 мая 2013 г., 9:41:20 (10 лет назад)

Не используй слишком большие числа(примерно до двух милиардов)

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int number, largest = 0;

   cout << "Enter the number: ";
   cin >> number;

   while(number != 0)
   {
      if(largest < number % 10)
      {
         largest = number % 10;
      }
      number /= 10;
   }

   cout << "The highest figure is " << largest << endl;

   return 0;
}

Ответить

Другие вопросы из категории

На столе в виде прямоугольника N×M лежат карточки, на которых написаны числа. Карточки лежат числами вниз. Известно, что в каждой строке числа

упорядочены по возрастанию слева направо и в каждом столбце числа упорядочены по возрастанию сверху вниз. Задаётся число X. За возможно меньшее количество переворачиваний карточек требуется найти карточку с числом X или заявить, что такой карточки на столе нет. Решите задачу в двух случаях: а) N=10, M=10; б) N=4, M=17.

В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.
Запрос Найдено страниц (в тысячах)
Чацкий & (Молчалин | Фамусов) 440
Чацкий & Молчалин 250
Чацкий & Фамусов 290
Компьютер печатает количество страниц (в тысячах), которое будет найдено по следующему запросу:Чацкий & Молчалин & ФамусовУкажите целое число, которое напечатает компьютер.Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.

Читайте также

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2



Вы находитесь на странице вопроса "1. Найти самую большую цифру целого числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.