Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

есть целочисленный массив из 20 эл-тов. нужно отсортировать массив по возрастанию эл-тов. числа любые.паскаль

5-9 класс

Doc20 15 нояб. 2015 г., 15:59:41 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bolik
15 нояб. 2015 г., 17:19:11 (8 лет назад)

a:array[1..20] of integer;
x, i:integer;
begin
for i:=1 to 20 do
readln(a[i]);
for i:=1 to 20 do
if a[i]>a[i+1] then begin
x:=a[i]; a[i]:=a[i+1]; a[i+1]:=x; end;
for i:=1 to 20 do
writeln(a[i]);
readln;
end.

Ответить

Другие вопросы из категории

Помогите срочно решить!!!!!!!
ОЧЕНЬ НУЖНО !!!!!!!!!!!!!!!!!!!Дано натуральное число , если оно двузначное и делится на сумму своих цифр, то его разделить на эту сумму, если оно

трехзначное и делится либо на 7, либо на 11, то его разделить на цело на 11. В остальных случаях разделить число на 10. ( сделать с помощью программы Pascal) Заранее огромное спасибо))))

Читайте также

Дан целочисленный массив из 20 элементов. Элементы массива принимают значения от 0 до 10000 включительно. Написать программу, позволяющую найти и выв

ести максимальное значение среди трехзначных элементов массива, делящихся на 4. Если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного класса. В баскетбольную команду бе

рут тех, чей рост не менее 180 см. Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что хотя бы один ученик играет в баскетбольной команде.Нужно паскаль

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.



Вы находитесь на странице вопроса "есть целочисленный массив из 20 эл-тов. нужно отсортировать массив по возрастанию эл-тов. числа любые.паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.