Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу, определяющую, принадлежит ли точка с координатами (x,y) кольцу с центром (x0,y0). R1 и r2 соответственно радиусы внутренней и внешней

10-11 класс

окружностей, образующих кольцо.

аааааууууууууууу 14 окт. 2014 г., 14:17:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelina20112001
14 окт. 2014 г., 15:25:55 (9 лет назад)

var  x,y,r1,r2:real;
begin
write('Введите x, y, внутренний радиус, внешний радиус: ');
readln(x,y,r1,r2);
if (x*x+y*y<=r2*r2) and (x*x+y*y>=r1*r1) then
  writeln('Да, принадлежит')
  else writeln('Нет, не принадлежит');
end. 

Ответить

Другие вопросы из категории

1)вывести все натуральные числа от 100 до 200 кратные 5

2) подсчитать общее кол-во делителей числа 100

Читайте также

Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.

Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

Дано задание "Составьте программу, определяющую, лежит ли точка с

указанными координатами X, Y на окружности радиуса R с центром в
начале координат." я её составил но почему у меня всегда получается что точка не лежит на окружности хотя она лежит. Может я где то ошибся ?

var


x,y,r:integer;


Begin


Write('Введите координату X: ');


Readln(x);


Write('Введите координату Y: ');


Readln(y);


Write('Введите длину радиуса R: ');


Readln(r);


If (sqr(x)+sqr(y))=r


then writeln('Точка лежит на
окружности!')


Else writeln('Точка не лежит на
окружности!');




End.

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Помогите составить программу. Даны действительные числа х и у, Определить принадлежит ли точка с координатами х,у заштрихованной области. Рисунок

предоставляю.
мне просто надо словами описать как это делать. (ну или условие if и тп и тп.)



Вы находитесь на странице вопроса "Написать программу, определяющую, принадлежит ли точка с координатами (x,y) кольцу с центром (x0,y0). R1 и r2 соответственно радиусы внутренней и внешней", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.