Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Через переменную х вводятся 10 чисел. Найдите количество положительных и отрицательных чисел. (составить программу)

5-9 класс

Tirik 10 апр. 2015 г., 5:00:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elena7577
10 апр. 2015 г., 6:59:52 (9 лет назад)

var
a:array[1..10]of integer;
k1, k2 , i: Integer;
Begin 
 k1 :=0;  k2 :=0; 
writeln('Введите массив:'); 
for i := 1 to 10 do 
 begin     
 write('A[',i,']=');     
readln(a[i]); 
 end; 
 for i := 1 to 10 do   
if a[i] > 0      then       
 Inc(k1)     
 else       
 if a[i] < 0         
 then           
Inc(k2);   
writeln('Np=',k1,'; Nn=',k2); 
 readln;
End.

Ответить

Другие вопросы из категории

Читайте также

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

В ПАСКАЛЕ!№1 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить сколько среди них чисел, кратных 4; №2 С клавиатуры вводятся 10

натуральных двузначных чисел. Определить

среднее арифметическое нечетных чисел;

№3 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить

верно ли, что среди введенных чисел есть число, в котором первая цифра в два раза больше последней.



Вы находитесь на странице вопроса "Через переменную х вводятся 10 чисел. Найдите количество положительных и отрицательных чисел. (составить программу)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.