Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста! Желательно с объяснениями!

10-11 класс

Какое количество информации получит второй игрок при игре в крестики-нолики на поле
размером 8x8 клеток, после первого хода первого игрока, играющего крестиками?

Spectre007 22 мая 2013 г., 11:59:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маримари
22 мая 2013 г., 14:31:50 (10 лет назад)

Т.к. всего 2 варианта хода - 0 или 1 (т.е. 1 bit), то:
N= 2^{i} ,
где N - кол-во всех вариаций (в данном случае 8*8=64), i - кол-во получаемой информации
N=2^{i} => 64= 2^{i} =>  2^{6}  =  2^{i}  => i = 6bit
Ответ: второй игрок получит 6 bit информации

Ответить

Другие вопросы из категории

Помогите описать алгоритм!!!

uses crt;


var s, sn, sg: string;


i: integer;


begin


write('s=');


readln(s); sn:='';


for i:=1 to length(s) do

Для кодирования

букв Е,П, Н, Ч, Ь используются двоичные
коды чисел 0, 1, 2, 3 и 4 соответственно (с
сохранением одного незначащего нуля
в случае одноразрядного представления).
Если таким способом закодировать
последовательность символов ПЕЧЕНЬЕ
и записать результат в восьмеричном
коде, то получится:


1) 1030240 2) 12017 3) 2141351 4) 23120

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Помогите пожалуйста! Желательно с объяснениями!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.