Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите пожалуйста решить задачу в Pascal ( и если можно Блок схему ) . Найти произведение элементов массива, кратных 3 и 9. Размерность массива -10.

10-11 класс

Заполнение массива осуществить случайными числами от 5 до 500. Срочном пожалуйста ребят !!

Gylchatai 06 авг. 2014 г., 12:47:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akku2001
06 авг. 2014 г., 13:37:41 (9 лет назад)

const n=10
var a:array [1..10] of integer;
i:byte; p:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(495)+5;
p:=1
for i:=1 to 10 do
if (a[i] mod 3=0) or (a[i] mod 9=0) then p:=p*a[i];
writeln('Произведение =', p);
readln;
end.
(Блок-схему можно легко составить, исходя из программы)

Ответить

Другие вопросы из категории

Си++

Дана матрица размером Nстрок и Mстолбцов. Найти количество положительных чисел в столбце.

Опишите

способы кодирования информации, снабдив их соответствующими примерами

составить программу для машины Тьюринга:

1)которая добавляет к слову из единиц две единицы слева;
2)которая сдвигает слово из единиц на две единицы вправо;
3)которая переводит слово муха в слово слон, а остальные слова удаляет.

Один стакан лимонада содержит 15 калорий, 1 кусок торта - 150 калорий, 1 драже "Тик-Так"- 2 калории. Во время праздничного обеда Буратино выпил 5 стакан

ов лимонада, съел 20 драже "Тик-Так" и 4 куска торта. Мальвина съела 2 драже "Тик-Так", 1 кусок торта и выпила 1 стакан лимонада. Пьеро выпил 2 стакана лимонада и съел 2 куска торта. Дуремар съел 3 куска торта и выпил 2 стакана лимонада.

Построить электронную таблицу, из которой будет видно: сколько всего стаканов лимонада было выпито, кусков торта и драже "Тик-Так" съедено; сколько калорий употребил каждый участник праздничного обеда; сколько калорий содержалось во всем выпитом лимонаде, всех съеденных кусках торта и драже "Тик-Так".

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код

Помогите пожалуйста решить задачу в Turbo Pascal!

Посчитать в двумерном массиве количество нечетных чисел если массив является квадратной матрицей то транспонировать его.



Вы находитесь на странице вопроса "Помогите пожалуйста решить задачу в Pascal ( и если можно Блок схему ) . Найти произведение элементов массива, кратных 3 и 9. Размерность массива -10.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.