Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 971 ответов!

Дан массив из 20 целостных элементов. Написать программу, которая подсчитывает и выводит на экран сумму и количество всех положительных элементов.

5-9 класс

Аливтинка1 26 янв. 2015 г., 20:53:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shamanaevaanna
26 янв. 2015 г., 21:37:12 (9 лет назад)

 

var

a:array [1..20] of integer;

i,s,k:integer;

begin

randomize;

k:=0;

s:=0; 

for i:=1 to 20 do begin

a[i]:=random(21)-10;

write (a[i],' ');

if a[i]>0 then 

begin

k:=k+1;

s:=s+a[i];

end;

end;

writeln;

writeln (k);

writeln (s);

readln;

end.

Ответить

Другие вопросы из категории

30 баллов!!! помогите срочно!!!

В программе описан двумерный массив A следующим образом
const N=5; M=6;
Type ARR=array[1..N,1..M] of integer;
var A: ARR;

Определить, как изменится в программе массив в результате вызова процедуры PAR(A).
procedure PAR(var A:ARR):
var I,J,MAXA,MINA,MAXI,MINI,B: integer;
begin MAXA:=A[1,1]; MINA:=A[1,1]; MAXI:=1; MINI:=1;
for I:=1 to N do
for J:=1 to M do
if A[I,J]>MAXA then
begin MAXA:=A[I,J]; MAXI:=I end
else if A[I,J] begin MINA:=A[I,J]; MINI:=I end;
if MAXI<>MINI then
for J:=1 to M do
begin B:=A[MAXI,J]; A[MAXI,J]:=A[MINI,J]; A[MINI,J]:=B end
end;

ПАСКАЛЬ Abc

придумать и решить задачу с применением условия "or".

№1. Дан массив напечатать:

1)все неотрицательные элементы.
2)все элементы не превышающие числа 10

№2
дан массив целых чисел.Напечатать:
1)все элементы кратные 5
2)все элементы заканчивающиеся 0

Читайте также

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
ПОЖАЛУЙСТА ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ ОТ НАЧАЛА ДО КОНЦА !!!

ОЧЕНЬ СРОЧНО!
Напишите программу, которая получив число ,выводит на экран соответствующий день недели. Например, ввели число 2, программа должна вывести "вторник". Если число не выходит за пределы 1...7, то должно быть выведено сообщение , сто такого дня нет.

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.



Вы находитесь на странице вопроса "Дан массив из 20 целостных элементов. Написать программу, которая подсчитывает и выводит на экран сумму и количество всех положительных элементов.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.