Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Pascal АВС - ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ, СРОЧНО!!!!!!!

10-11 класс

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
· Если все числа не превышают 30, то выведите их удвоенное произведение.
· Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в десять раз.
· Если выполняются одновременно два перечисленных выше условия, то выведите эти числа без изменения.
· Иначе, выведите разность первого и последнего чисел.
Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Заранее спасибо.

Riza66 23 июля 2015 г., 6:05:36 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pandaolgaha
23 июля 2015 г., 7:13:37 (8 лет назад)

var   
a,b,c,d,p : integer;
    r : real;
begin
readln (a,b,c,d);
p := 0;
if (a<=30) and (b<=30) and (c<=30) and (d<=30) then
      begin     
p := p +1;     
 r:= a*b*c*d*2;
      end;
if d mod 2 = 0 then
    begin   
 r := a*b/10;   
 p := p + 1;   
end
;case p of
0 : writeln (a-d);  //Как я понял иначе (все условия не выполняются)
1 : writeln (r);
2 : writeln (a,' ',b,' ',c,' ',d); 
end;
end.

Ответить

Другие вопросы из категории

Решите задачу на паскале с циклом с предусловие и пост условием.

Составьте программу, выводящую на экран квадраты чисел от 10 до 20

В книге содержится 48 страниц, в каждой из которых 64 строки, каждая строка состоит из 32 символов, включая пробелы и знаки препинания. Книга хранится на д

иске в виде текстового файла, закодированного шестнадцатибитным кодом UNICODE. Каков информационный объем данного файла в килобайтах?

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "Pascal АВС - ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ, СРОЧНО!!!!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.