Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Перед началом учебного года все школьники проходят медицинский осмотр, каждому измеряют рост и вес. Для каждого первоклассника необходимо также определить

5-9 класс

тип парты (по росту, всего 3 типа). Проведите медицинский осмотр 500 школьников.

Составьте программу, содержащую процедуру, отвечающую за измерение роста и веса, и функцию, отвечающую за определение типа парты первоклассника.
Шкала типа парт:
140<=
140-150
>=150
Программу составить в Pascal ABC
Помогите пжлста!

Stasvirus46222 15 февр. 2014 г., 17:27:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valerija989
15 февр. 2014 г., 19:21:04 (10 лет назад)

procedure GetRV(var r, v: real; var Final: boolean);
{ Организует ввод и возвращает значения роста и веса.
  Значение параметра Final=true - сигнал окончить ввод данных,
  для чего вводят нули }
begin
  Write('Введите рост (см) и вес (кг) ->');
  Readln(r, v);
  Final := ((r > 0) and (v > 0))
end;

function DefDesk(r: real): string;
begin
  if r <= 140 then DefDesk := 'S'
  else if r < 150 then DefDesk := 'M'
  else DefDesk := 'L'
end;

var
  rost, ves: real;
  flag: boolean;

begin
  repeat
    GetRV(rost, ves, flag);
    if flag then Writeln('Нужна парта типа ', DefDesk(rost))
  until (not flag)
end.

Тестовое решение:
Введите рост (см) и вес (кг) ->135 31
Нужна парта типа S
Введите рост (см) и вес (кг) ->143 41
Нужна парта типа M
Введите рост (см) и вес (кг) ->151 48
Нужна парта типа L
Введите рост (см) и вес (кг) ->0 0



+ 0 -
Ivanna1715
15 февр. 2014 г., 21:04:09 (10 лет назад)

Где придуманная Вами шкала типа парт?

Ответить

Читайте также

Найдите в списке шесть парНайдите в списке шесть пар множеств,между которыми существуют отношениНайдите в списке шесть пар множеств,между

которыми существуют отношения "является разновидностью":
гриб,человек,здание,школьник,школа,врач,растение,дерево,яблоня,подосиновик

Заполните таблицу:запишите для каждого подмножества одно дополнительное свойство.


1.Множество 2.Подмножество 3.Дополнительный признак подмножества

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

37 школьников из ученической производственной бригады изъявили желание летом работать на уборке зерновых. Каждый из них имеет права для работы на

тракторе или на комбайне, а некоторые могут работать и на тракторе, и на комбайне. Сколько школьников могут работать и на тракторе, и на комбайне, если известно, что трактором хорошо овладели 23 человека, а комбайном - 31 человек?

1) В каком году российские школьники началаи изучать информатику? а)1958; б)1985; в) 1998; г)2000. 2) Найдите лишнее (по

проприетарности):

а) adobe photoshop; б) adobe flash professional; в)adobe reader; г) adobe flash player

3)В классическом паскале нету функции возведения в степень. Если программисту на паскале всёже потребуется возвести число а>0 в степень n, то с помощью какого выражения он может это сделать?

a) exp(ln(a)*n; б) exp(ln(n)*a; в) ln(exp(a)*n; г) ln(exp(n)*a.



Вы находитесь на странице вопроса "Перед началом учебного года все школьники проходят медицинский осмотр, каждому измеряют рост и вес. Для каждого первоклассника необходимо также определить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.