Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу, находящую номер минимального элемента массива

10-11 класс

Lerchik24 24 июня 2014 г., 23:49:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ягодка123459854
25 июня 2014 г., 0:40:09 (9 лет назад)

var A:array[1..5] of integer;
i,ii,min:integer
;begin
for i:=1 to 5 do 
 begin
 A[i]:=1+Random(9); 
 Write(A[i]:2)
 end;
 Writeln;
 min:=A[1]; 
 for i:=1 to 5 do
  if A[i]>min then
 begin
 min:=A[i];
 ii:=i; end; 
 Writeln('min: ',min,' ind: ',ii);
end.

Ответить

Другие вопросы из категории

Улитка ползёт по вертикальному шесту высотой h метров, поднимаясь за день на a метров, а за ночь спускаясь на b метров. На какой день улитка доползёт

до вершины шеста? Программа получает на вход натуральные числа h, a, b и должна вывести одно натуральное число. Гарантируется, что a>b. При решении этой задачи нельзя пользоваться условной инструкцией if и циклами. Примеры Входные данные 10 3 2 Выходные данные 8

Перевести в форму, принятую в Бейсике: 257,15х10^-15

y=cosax/(n-1)x^n+2-a/n-1

Помогите пожалуйста)

1) Количество единиц в двоичной записи десятичного числа 1023

2) количество значащих нулей в двоичной записи десятичного числа 501


Читайте также

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Дан двумерный массив a размером n*n. Написать программу определения номера столбца с максимальной суммой элементов. Дан двумерный массив

а размером n*n. В каждой строке изменить значения элементов, стоящих за минимальным элементом этой строки, на 1

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.



Вы находитесь на странице вопроса "Написать программу, находящую номер минимального элемента массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.