Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

5-9 класс

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:

OkNastyaok1997 31 янв. 2014 г., 15:00:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MaryMay2000
31 янв. 2014 г., 15:51:03 (10 лет назад)

k:=0
sum:=0
for i:=1 to 10 do
begin
if m[i]<0 then
begin
k:=k+1;
sum:=sum+m[i];
end;
end;
writeln(sum/k);
end.

Ответить

Другие вопросы из категории

Какие бывают виды сканеров?
1.На вокзале 8 путей.Вам сообщили,что поезд приедет на 4 путь.Сколько информации вы получили?

2.В коробке 6 фломастером.Сколько информации,что достали синий?

По русски юзер это ?

Читайте также

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);



Вы находитесь на странице вопроса "Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.