Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу 1)Даны действительные числа a,b,c. Если выполняется a>b>c, то каждое число заменить наибольшим, в противном случаи заменить их

5-9 класс

модулями.

Styleandhelthy 23 сент. 2013 г., 15:10:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anet04
23 сент. 2013 г., 16:50:22 (10 лет назад)

program gt;
var q,a,b,c,max:real;
begin
readln(a,b,c);
max:=a;
if(b>max)then max:=b;
if(c>max)then max:=c;
q:=0;
if(a>b)and(b>c)then begin
a:=max;
b:=max;
c:=max;
q:=1;
end;
if(q=0)then begin
a:=abs(A);
b:=abs(b);
c:=abs(c);
end;
writeln(a,' ',b,' ',c);
end.  


Ответить

Читайте также

Пароль от почтового ящика в виде четырехзначного числа Вася

зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов
ведется вправо налево начиная с нуля), циклически сдвигаются вправо, а
нечетные-влево на количество позиций, равных номеру разряда. Так,
например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1
(7->8->9->0->1). Затем из нечётных цифр вычитается, а к
чётным прибавляется 1. Далее оба шага повторяется еще один раз. В
результате шифровки получилось число 3216. Определите пароль.

Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов ведется вправо налево

начиная с нуля), циклически сдвигаются вправо, а нечетные-влево на количество позиций, равных номеру разряда. Так, например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1 (7->8->9->0->1). Затем из нечётных цифр вычитается, а к чётным прибавляется 1. Далее оба шага повторяется еще один раз. В результате шифровки получилось число 3216. Определите пароль.

Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов ведется вправо

налево начиная с нуля), циклически сдвигаются вправо, а нечетные-влево на количество позиций, равных номеру разряда. Так, например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1 (7->8->9->0->1). Затем из нечётных цифр вычитается, а к чётным прибавляется 1. Далее оба шага повторяется еще один раз. В результате шифровки получилось число 3216. Определите пароль.

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.



Вы находитесь на странице вопроса "Составить программу 1)Даны действительные числа a,b,c. Если выполняется a>b>c, то каждое число заменить наибольшим, в противном случаи заменить их", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.