Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста..

10-11 класс

Alexzaidov 24 авг. 2015 г., 9:14:49 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fuyy
24 авг. 2015 г., 10:28:06 (8 лет назад)

1) После do не нужна точка с запятой. Будет напечатано:
 1  2
2) Паскаль АВС:
Program  Nati22;
uses crt
const
  n=15;
var
  mass: array [1..n] of integer;
  i,k,m: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Среди элементов массива программа находит числа, которые больше заданного m, и заменяет их на 0');
  write('Введите m '); readln(m);
  writeln('*** Вычисляю... ***');
  randomize;
  k:=0;
  for i:=1 to n do begin
    mass[i]:=random(100)-50;
    if mass[i] >m then
    begin
      mass[i]:=0;
      k:=k+1;
    end;
  end;
writeln ('Итоговый массив: ');
for i:=1 to n do write(mass[i],'  ');
writeln ();
writeln ('Всего было заменено ',k,' элементов ');
end.

3) Ответ 2) 0 1 2 3 4 5 6 7 8 9 10

Ответить

Другие вопросы из категории

Помогите пожалуйста с информатикой.

Записать числа 19,99(10); 10,10(2); 64,5(8); 39,F(16) в развернутой форме.

Как решить эту задачу?

Про­из­во­дит­ся четырёхка­наль­ная (квад­ро) зву­ко­за­пись с ча­сто­той дис­кре­ти­за­ции 16 кГц и 32-бит­ным раз­ре­ше­ни­ем, ре­зуль­та­ты за­пи­сы­ва­ют­ся в файл, сжа­тие дан­ных не ис­поль­зу­ет­ся. Раз­мер файла с за­пи­сью не может пре­вы­шать 20 Мбайт. Какая из при­ведённых ниже ве­ли­чин наи­бо­лее близ­ка к мак­си­маль­но воз­мож­ной про­дол­жи­тель­но­сти за­пи­си?

Информация о количестве жильцов в каждой из четырех квартир каждого этажа 12-этажного дома хранится в двумерном массиве (в первой строке -

информация о квартирах первого этажа, во второй - второго и т. д.) . В каждой квартире проживает одна семья. Найти численность самой большой семьи в квартирах 3-го и 4-го этажей. (Pascal)

Помогите с номером 5

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "помогите пожалуйста..", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.