Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

найти периметр пятиугольника по известным координатам его вершин,используя процедуру вычисления длины отрезка по известным координатам его концов

5-9 класс

Jaisor 30 июля 2013 г., 0:45:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valeraholkin
30 июля 2013 г., 1:40:35 (10 лет назад)

function Len(x1,y1, x2, y2:real):real;

begin

   Len := sqrt( sqr(x1 - x2) + sqr(y1 - y2) );

end;

 

var

  x1,x2,x3,x4,x5, y1, y2, y3, y4, y5:real;

begin

   write('x1 = '); readln(x1);

   write('y1 = '); readln(y1);

   write('x2 = '); readln(x2);

   write('y2 = '); readln(y2);

   write('x3 = '); readln(x3);

   write('y3 = '); readln(y3);

   write('x4 = '); readln(x4);

   write('y4 = '); readln(y4);

   write('x5 = '); readln(x5);

   write('y5 = '); readln(y5);

   writeln('P = ', Len(x1,y1,x2,y2) + Len(x2,y2,x3,y3) + Len(x3,y3,x4,y4) + Len(x4,y4,x5,y5) + Len(x5,y5,x1,y1));

end.

 

Ответить

Другие вопросы из категории

Помогите пожалуйста решить задачу.

Найти периметр треугольника. с помощью Паскаля
там Program,Var и тд. заранее спасибо

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.

Читайте также

помогите!нужно решить до завтра.завтра последний день сдачи индивидуальной работы. «Программирование» 9 класс Задание №1 записать по правилам

изучаемого языка программирования следующие выражения:γ m1m2/r^2 Задание 2 «Вычисления по известным формулам». Написать программу:Найти площадь трапеции по известным основаниям и высоте. Задание №3 «Выделение цифр в записи числа» Написать программу:Дано трехзначное число. Верно ли, что оно заканчивается цифрой 7? Задание №4 «Условный оператор» Написать программу:Даны два целых числа. Составить программу, которая большее число возводит в квадрат, а меньшее увеличивает на 10. Если числа равны, то вывести сообщение «ЧИСЛА РАВНЫ». Задание №5 «Циклы» Написать программу:Напишите программу, которая на отрезке от а до в, выводит на экран все четные числа, оканчивающихся нулем.



Вы находитесь на странице вопроса "найти периметр пятиугольника по известным координатам его вершин,используя процедуру вычисления длины отрезка по известным координатам его концов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.