Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Последовательно

10-11 класс

вводятся N целых чисел. Определить, каких среди них чисел
больше: положительных или отрицатель­ных.

Нужно построить блок-схему, заранее спасибо

LizonkaKabisheva 02 мая 2013 г., 3:38:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Joudy
02 мая 2013 г., 5:54:20 (10 лет назад)

const
    N = 10; //твое число N
var
    i,c,nc,X: integer;
begin
for i:=1 to N do
begin
    READLN(X);
    if(X >= 0) then inc(c)
    else inc(nc);
end;
  
if (c > nc) then Writeln('четных больше')
else
begin
    if(c < nc) then Writeln('нечетных больше')
    else if(c = nc) then writeln('кол-во четных и нечетных чисел равно');
end;
end.  

+ 0 -
Keti5666
02 мая 2013 г., 7:17:08 (10 лет назад)

ЗАДАЧА НА ЦИКЛИЧЕСКИЕ АЛГОРИТМЫ С ИЗВЕСТНЫМ КОЛИЧЕСТВОМ ПОВТОРЕНИЙ

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА ПОМОГИТЕ

Оформите титульный лист в MS Word,
содержащий:

отметить причины по которым иногда требуется сжимать файл 1)файл занимает много места на диске 2)файлы нужно перенести на другой компьютер 3)файлы часто

используются 4)необходимо защитить данные от просмотра 5)файлы надо передать через интернет

Читайте также

На Паскале решить задачу. Задан целочисленный вектор Х размерностью n, представляющий последовательность целых чисел. Определить число инверсий

в этой последовательности.

рекомендации: инверсией считать пару элементов, в которой большее число находится перед меньшим (хi>xj, если i>j)

Дана последовательность чисел 0, 0, 1,

1, 2, 4, 7, 3, 4, 4 … , каждый элемент этой последовательности, начиная с
четвёртого равен последней цифре суммы трёх предыдущих элементов. Найдите
значение 1400-го элемента этой последовательности.



Ответ: ______________

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

написать программу на языке С#:. Последовательность

целых ненулевых чисел вводится с клавиатуры. Окончанием последовательность
является 0. Определите

произведение чисел, которые делятся на 5



Вы находитесь на странице вопроса "Последовательно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.