Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Паскаль.

5-9 класс

На интервале от 100 до 300 найти среднее арифметическое чисел, кратное 10.

лики12345 10 мая 2014 г., 8:19:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
таки
10 мая 2014 г., 10:41:25 (9 лет назад)

var
k, i:integer;
SrAr:real;
 
begin
k:=0;
s:=0;
for i:=100 to 300 do
if i mod 10=0 then
  begin
  k:=k+1;
  s:=s+i;
  end; 
SrAr:=s/k;
writeln(Sr:5:2);
end.

Ответить

Другие вопросы из категории

Составьте алгоритм решения следующей задачи. Как переправиться на другой берег реки трем рыцарям и оруженосцам, если имеется двухместная лодка и известно,

что оруженосец не плывет и не остается на берегу с чужими рыцарями без товарищей?
b)У исполнителя Вычислитель две команды:
1. x+n
Это означает, что если точка имеет координаты (x,y), то новая координата по x становится равной x+n. Координата по y при этом становится равной y+2n-10.
2. y+m
Это означает, что если точка имеет координаты (x,y), то новая координата по y становится равной y+m. Координата по x при этом становится равной x+40-m. Команды разделяются запятыми. Например, программа x+1, y+1 переводит точку с координатами (100,100) в точку с координатами (140,93). Известно, что программа x+25, y+32 перевела некоторую точку в точку (67, 76). Найти координаты начальной точки.

Как составить на языке Паскаль программу вычисления суммы всех натуральных чисел, не

превышающих заданного натурального числа N?

Вообще с Паскалем у меня полный завал! Если знаете как, то напишите! Желательно с объяснениями, буду благодарна!

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Паскаль, в его первоначальном виде, представляет собою чисто процедурный язык.

Простейшая программа на Паскале будет выглядеть следующим образом:
program upr;
begin
writeln ( ? ); {оператор вывода строки}
end.
Определи, какая фраза пропущена на месте вопросительного знака?
’Hello, World!’
“Lorem ipsum”
Just Another Perl Hacker

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i



Вы находитесь на странице вопроса "Паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.