Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Выполнить в paskal

10-11 класс

N=12 Ввести число К Определить количество элементов массива, значения которых больше K.
...
Все элементы массива увеличить в 3 раза. Массив вывести.
...
Определить максимальное значение сред положительных элементов массива.

Lika9830 22 авг. 2014 г., 3:38:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Катюшенько
22 авг. 2014 г., 4:12:15 (9 лет назад)

const
  n = 12;

var
  a: array[1..n] of integer;
  i, k, p, max: integer;

begin
  Randomize;
  Write('Введите число К: ');
  Readln(k);
  Write('Элементы массива: ');
  p := 0;
  for i := 1 to n do
  begin
    a[i] := Random(101)-50;
    Write(a[i]:5);
    if a[i] > k then p := p + 1;
  end;
  Writeln(#13#10, 'Количество элементов, больших ', k, '=', p);
  max := -32768;
  for i := 1 to n do
  begin
    a[i] := 3 * a[i];
    if max < a[i] then max := a[i]
  end;
  if max > 0 then Writeln('Максимальный элемент массива равен ', max)
  else Writeln('В массиве нет положительных элементов')
end.

Тестовое решение:
Введите число К: 25
Элементы массива:   -10   43   -6    8   -4   39   26  -30  -33  -10  -34   -4
Количество элементов, больших 25=3
Максимальный элемент массива равен 129


+ 0 -
Оливка17
22 авг. 2014 г., 7:00:32 (9 лет назад)

Вообще-то язык называется Pascal

Ответить

Другие вопросы из категории

Помоите решить.Циклы(паскаль).В послед a1,a2,a3,...an каждый член, начиная с четвёртого, равен последней цифре суммы трёх предыдущих. Найти n-ый

элемент последовательности.Да хотелось бы еще чтобы каждая строчка была расписана что в ней происходит.

Математическая модель объекта - это описание объекта-оригинала в виде:

a. Рисунка
b. Схемы
c. Графика функции
d. Текста

Помогите очень надо!!

Составить программу,которая определяет возраст человека по количеству дней, с учётом год, года,лет. в раскале!

TURBO Pascal

var
i,N:integer;
begin
writeln('Vvedite N');
readln(N);
for i:=1 to n do
if (i mod 2<>0)and(i mod 3<>0)and(i mod 5<>0)then writeln(i);
readln
end.

Данная программа выдает все числа, от 1 до заданного (n), которые не делятся без остатка на 2,3,5. что нужно исправить, чтобы программа выдавала только количество этих чисел.
Заранее спасибо.

Читайте также

Выполнить в paskal

....
Ввести слово. Вывести слово, полученное путем перестановки местами половинок введенного слова.
....
Ввести строку. Подсчитать , сколько в ней символов * D F H.
....
Ввести строку. Удалить из нее все цифры.

Задание 11. Выполните арифметические действия.

1) 110 + 101;
2) 10101-11;
3) 101 ´ 11;
4) 1110:10.

Задание 12. Выполните арифметические действия:

а) 11102 + 10012;
б) 678 + 238;
в) AF16 + 9716;
г) 11102 - 10012;
д) 678 - 238;
e) AF16 - 9716;
ж) 11102 × 10012;
з) 678 × 238;
и) AF16 × 9716;
к) 10102 : 102;
л) 748 : 248;
м) 5А16 : 1Е16.

Какие функции выполняет прикладное ПО?

Выберите один или несколько ответов:
Антивирусная защита
Табличная обработка данных
Машинная и деловая графика
Работа с базами данных
Обработка текстовКакие функции выполняет прикладное ПО?

20,9- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления. Выполнить в этих системах их сложение, вычитание и умножение. Ответ записать в 10-ой

системе счисления.

80,1- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления.

Выполнить в этих системах их сложение, вычитание и умножение.

Ответ записать в 10-ой системе счисления.

1. Выполнить сложение:

а) 10000011(2)+1000011(2); б) 1010010000(2)+1101111011(2); в) 110010,101(2)+1011010011,01(2); г) 356,5(8)+1757,04(8); д) 293,8(16)+3CC,98(16).
2. Выполнить вычитание: а) 100111001(2)-110110(2); б) 1111001110(2)-111011010(2); в) 1101111011,01(2)-101000010,0111(2); г) 2025,2(8)-131,2(8); д) 2D8,4(16)-A3,B(16).
3. Выполнить умножение:
а) 1100110(2)× 1011010(2); б) 2001,6(8)× 125,2(8); в) 2C,4(16)× 12,98(16).
4. Выполнить деление:
а) 110011000(2) : 10001(2); б) 2410(8) : 27(8); в) D4A(16) : 1B(16);



Вы находитесь на странице вопроса "Выполнить в paskal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.