Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан целочисленный

5-9 класс

двумерный массив 6x10. Опишите на
русском языке и на языке программирования Паскаль алгоритм вычисления
произведения минимальных элементов из каждой строки. Напечатать значение этого произведения.
Предполагается, что в каждой строке минимальный элемент единственный.

Saydulaeva2014 31 дек. 2013 г., 6:41:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KIM16
31 дек. 2013 г., 7:58:50 (10 лет назад)

Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

uses crt;
const n=6;m=10;
var i,j,min,ans:integer;
a:array[1..n,1..m] of integer;
begin
ans:=1;
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(1,20);
write(a[i,j]:3);
end;
writeln;
end;
for i:=1 to n do
begin
min:=a[i,1];
for j:=2 to m do
if a[i,j]<min then
min:=a[i,j];
ans:=ans*min;
end;
writeln(ans);
end.

Ответить

Другие вопросы из категории

Решите задачу, использую круги Эйлера или схему состава.

В летнем лагере отдыхало 86 семиклассников. 8 из них не любят играть в компьютерные игры. 54 семиклассника предпочитают квесты, 62 - симуляторы. Сколько ребят с одинаковым удовольствием играют и в квесты, и в симуляторы?

Могут ли существовать

Читайте также

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного класса. В баскетбольную команду бе

рут тех, чей рост не менее 180 см. Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что хотя бы один ученик играет в баскетбольной команде.Нужно паскаль

Дан целочисленный массив из 20 элементов. Элементы массива принимают значения от 0 до 10000 включительно. Написать программу, позволяющую найти и выв

ести максимальное значение среди трехзначных элементов массива, делящихся на 4. Если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.



Вы находитесь на странице вопроса "Дан целочисленный", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.