Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

(1) вариант

10-11 класс

1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > 28 и их среднее арифметическое
2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные
3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол-во и сумму положительно ввёдных чисел

Rusaladikova 11 янв. 2014 г., 4:27:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanesh
11 янв. 2014 г., 5:01:21 (10 лет назад)

1. var a:array[1..10] of integer;
   n, i: integer;
s:real;
begin
for i:=1 to 10 do
readln(a[i]);
s:=0;n:=0;
for i:=1 to 10 do 
if a[i]>28 then begin s:=s+a[i]; n:=n+1 end;
if n>0 then writeln(n,s/n) else writeln('net >28')
end.

Ответить

Читайте также

Помогите срочно, надо вариант 4! Сделать при помощи VBA и проверить в экселе

Вычислить значение функции по формуле. Значение аргумента x принадлежит[0,1;0,6]
вариант 4

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Какое минимальное основание может иметь система счисления, если в ней записано число 653? Варианты ответа:!)10 2)6 3)7 4)3

Бывают логическое, строковое, арифметическое: Варианты ответов 1) предложение 2)высказывание 3) выражение 4) мышление
Чем заканчивается программа? Варианты ответов !) Read 2) Clrscr 3) ReadLn 4) End

Помогите срочно надо Вариант 1. 78 48 35 5 50 44 75 38

Упражнение 1.
Выполните сортировку элементов из вашего варианта методами: пузырьком,вставками, бинарными вставками, выбором. Приведите примерыпоследовательностей, показывающих, что сортировки выбором, бинарнымивставками являются неустойчивыми.Упражнение
2.
Упорядочите элементы из вашего варианта по неубыванию следующимисортировками: быстрой, пирамидальной. Приведите примеры последовательностей,показывающих, что быстрая и пирамидальная сортировки являются неустойчивыми



Вы находитесь на странице вопроса "(1) вариант", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.