Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Задача A Доска Задается N. Нужно вывести цвет каждой клетки доски N x N,

10-11 класс

если известно, что они покрашены в шахматном порядке и клетка (1, 1) - белая.

Формат входных данных

Первая строка входного файла содержит единственное целое N (1 <= N <= 10).

Формат выходных данных

Выведите N строк в каждой N символов соответствующий цвету этой ячейки: ‘W’ – если белая и ‘B’ – если черная.

Ильмир 27 янв. 2014 г., 8:03:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gcdrrdyfchtc468
27 янв. 2014 г., 9:02:47 (10 лет назад)

var
   n, i, j: integer;
begin
     readln(n);
     for i := 1 to n do
     begin
         for j := 1 to n do
             if ((j + i) mod 2 = 0) then
                write('W':2)
             else
                 write('B':2);
         writeln;
     end;
end.

Ответить

Другие вопросы из категории

(1) вариант

1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > 28 и их среднее арифметическое
2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные
3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол-во и сумму положительно ввёдных чисел

Читайте также

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».



Вы находитесь на странице вопроса "Задача A Доска Задается N. Нужно вывести цвет каждой клетки доски N x N,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.