Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Информатика, Pascal

5-9 класс

Цикл с предусловием
Напишите программу, которая будет находить первую цифру числа.

Lyizaa 19 сент. 2013 г., 11:58:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Artemka12211996
19 сент. 2013 г., 13:02:44 (10 лет назад)

var a:integer;
begin
readln(a);
while a>=1 do
a:= a div 10;
writeln(a);
end.

Ответить

Другие вопросы из категории

Шестиклассники Аня , Боря , Вася , Галя , Даша и Иван получили в подарок флешки на 1, 2, 4, 8, 16, и 32 Гб .Выясните ,кто из ребят получил флешку самого

большого объема и кто - самого маленького объема, если известно следующее : У Ани объем флешки меньше , чем у Бори. А у Васи больше чем у Гали. У Даши меньше чем у Ивана. У Васи меньше чем у Ани.У Даши больше чем у Бори.

7. В доме у Пети установили новый лифт экспериментальной модели. В этом лифте все кнопки с номерами этажей заменены двумя кнопками. При нажатии на одну

из них лифт поднимается на один этаж вверх, а при нажатии на вторую - опускается на один этаж вниз. Пете очень по¬нравился новый лифт, и он катался на нем, пока не побывал на каждом из этажей хотя бы по одному разу. Известна последовательность кно¬пок, которые нажимал Петя: 1221221221. Каково количество этажей в доме у Пети? c какого этажа петя начал кататься на лифте? на каком этаже петя закончил свой эксперимент?

1. Массивы, обращение к элементам которых осуществляется при помощи только одного индекса, называются.....(одномерными, одноместными, прямыми)

2. Диапозон индексов массива определяет его......( тип, размер, имя)
3. Алгоритм поиска называется последовательным. ( да, нет )

Читайте также

Информатика (Pascal):

Написать программу для след задачи:

Найти среднюю температуру, если кол-во n дней, когда t >=5.
Вывести ДА или НЕТ

Информатика Pascal помогите!!
Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

Помогите сделать по информатике задание :

Закончите определения .
а) Информатика - это наука ______________________________________________________________________________________________________________________________________________________________
б) География - это наука _____________________________________________________________________________________________________________________________________________________________
в) Фонетика - это раздел науки о _________________________________________________________________________________________________________________________________________________________
г) Ботаника - это раздел науки о __________________________________________________________________________________________________________________________________________________________
д) Имя существительное - это самостоятельная часть речи , __________________________________________________________________________________________________________________________________________________________
е) Глагол - это самостоятельная часть речи , __________________________________________________________________________________________________________________________________________________________
ж) Земледельцы - это люди , _________________________________________________________________________________________________________________________________________________________
з) Животноводы - это люди , __________________________________________________________________________________________________________________________________________________________
и) Тяжёлая промышленность - это _________________________________________________________________________________________________________________________________________________________
к) Лёгкая промышленность - это _________________________________________________________________________________________________________________________________________________________
Мне обязательно сделать под буквами д , е , ж ( желательно ) , з , и , к . Сделаете хотябы под этими буквами , обязательно поставлю на лучший ( если найду конечно ) !

Помогите срочно! По информатике задали 7 вопрос: Возле школы растут шесть деревьев: сосна, берёза, липа, тополь, ель и клён. Какое из этих деревьев самое

низкое, если известно, что берёза ниже тополя, липа выше клёна, сосна ниже ели, липа ниже берёзы, сосна выше тополя?
И второй вопрос: Пятеро одноклассников - Аня, Саша, Лена, Вася и Миша - стали победителями школьных олимпиад по истории, математике, информатике, литературе и географии. Известно, что: 1) победитель олимпиады по информатике учит Аню и Сашу работе на компьютере; 2) Лена и Вася заинтересовались информатикой; 3) Саша всегда побаивался истории; 4) Лена, Саша и победитель олимпиады по литературе занимаются плаванием; 5) Саша и Лена поздравили победителя олимпиады по математике; 6) Аня сожалеет о том. что у неё остаётся мало времени на литературу.
Победителем какой олимпиады стал каждый из этих ребят?



Вы находитесь на странице вопроса "Информатика, Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.