Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу которая принимает с клавиатуры положительное трехзначное число а затем вычисляет и выводит на экран его "степень четности". на PASKAL

10-11 класс

Jumpick1 26 янв. 2015 г., 6:43:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cerkevich1
26 янв. 2015 г., 9:17:13 (9 лет назад)

var n, k :integer;
Begin
    read(n);
    k := 0;
    while (n mod 2 = 0) begin
        k := k + 1;
        n := n div 2;
    end;
    writeln(k);
End.

Ответить

Читайте также

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.



Вы находитесь на странице вопроса "Напишите программу которая принимает с клавиатуры положительное трехзначное число а затем вычисляет и выводит на экран его "степень четности". на PASKAL", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.