Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Очень нужна помощь. Помогите найти ошибки - Паскаль.

5-9 класс

Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами.

Не совсем то выводит, и модуль может как-то через abs надо.

program proizvedenie;
var q,z,w,i,n,i1,i2:integer;
a:array[1..1000] of real;
amin,amax,pr:real;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
amin:=a[1];
for i:=1 to n do
begin
if a[i]<amin then
begin
amin:=a[i];
i1:=i;
end;
end;
amax:=a[1];
for i:=1 to n do
begin
if a[i] > amax then
amax:=a[i];
i2:=i;
end;
if i2>i1 then begin
q:=i1;
w:=i2;
end
else begin
q:=i2;
w:=i1;
end;
if (w-q)>1 then begin
pr:=1;
for z:=q to w do
pr:=pr*a[z];
end
else write (0);
close (input);
close (output);
end.

1901bkl 21 сент. 2013 г., 0:13:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polina20222
21 сент. 2013 г., 1:05:38 (10 лет назад)

не гарантирую, что нет иных ошибок, но:
for z:=q to w do
pr:=pr*a[z];

Ответить

Другие вопросы из категории

бабушка прислала ивану посылку ч яблоками и грушами. некоторые из них большие, остальные-маленькие. по цвету плоды тоже различались:зеленые и желтые.

среди плодов не было маленьких груш и маленьких зеленых яблок. яблок было-25, а груш-17. большихплодов было 32. желтых плодов 28. зеленых яблок на два больше, чем. зеленых груш. иван угостил друзей фруктами. им больле всего понравились большие желтые яблок. сколько было таких яблок

задача по информатике в Pascal ABC
ответьте пожалуйста

Читайте также

Нужна помощь в составлении алгоритма (паскаль АВС) -8 класс.

1 задание: Составьте программу вычисления количества двухзначных чисел,которые кратны 2 и 3.
2 задание: Составьте программу,выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.
3 задание: Найдите количество двузначных чисел,которые делятся на сумму своих цифр.
P.S. Помогите пожалуйста! Очень нужно и срочно! Если можете,то нужно всё сделать; если же нет,то хотя-бы одну или две задачи. Заранее спасибо!!!)))

помогите плиз очень нужно:превратите одно слово в другое всякий раз заменяя по одной букве так,чтобы новое слово было существительным в именительном падеже

.
а)ночь-?-?-?-?-?-день
б)рота-?-?-?-?-?-полк
в)бант-?-?-?-?-?-коса
г)бег-?-?-?-?-?-?-?-шаг
д)море-?-?-?-?-?-?-суша
е)миг-?-?-?-?-?-?-?-век
помогите очень нужно,учительница ужасно строгая ненавидит меня помогите!

с начала суток часовая стрелка повернулась на угол бета определите показание часов в этот момент времени!

Очень нужна помощь! Помогите пожалуйста, в паскале!

Оооочень нужна помощь, помогите с информатикой, плиз

1.Вводится действительное число x. Вычислить значение функции x^3+(2√(x-2))/(3+x^2 )
Нужно написать программу в Pascal.
2.Написать программу для задачи: вводится двухзначное число, выяснить из одинаковых цифр оно состоит или нет.



Вы находитесь на странице вопроса "Очень нужна помощь. Помогите найти ошибки - Паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.