Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

прочитайте из файла целые числа, увеличьте на 2 и выведите их на экран.

5-9 класс

наташа2014112 26 авг. 2013 г., 18:22:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
777original777
26 авг. 2013 г., 19:04:34 (10 лет назад)

uses crt;
var input:text;
    a:integer;
begin
     assign(input,'input.txt');
     reset(input);
     while not EOF(input) do
     begin
          readln(input, a);
          a:=a+2;
          writeln(a);
     end;
     close(input);
end.

Ответить

Другие вопросы из категории

1. Определите тип выравнивания для каждого из приведённых ниже фрагментов:

Фрагмент 1
Для представления текстовой информации в компьютере используется алфавит мощностью 256 символов. Двоичный код каждого символа в ком-пьютерном тексте занимает 1 байт памяти.

Фрагмент 2
Таблица кодировки – это таблица, в которой всем символам компьютер-ного алфавита поставлены в соответствие порядковые номера и их двоичные коды.

Фрагмент 3
Все символы кодировочной таблицы пронумерованы от 0 до 255. Каждому номеру соответствует двоичный код от 000000000 до 111111111. Для разных типов ЭВМ существуют разные таблицы кодировки. Для компьютеров типа IBM PC международным стандартом стала кодировочная таблица ASCII (American Standart Code for Information Interchange).

Фрагмент 4
Первая половина этой таблицы имеет международный стандарт (символы от 0 до 127), вторая половина называется кодовой страницей и существует в различных вариантах

Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях ("включено" и "выключено"). Какое наименьшее количество лампочек

должно находиться на табло, что бы ч его помощью можно было передать 500 различных сигналов?
1)8 2)9 3)100 4)200

Читайте также

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Вставьте пропущенные слова в описании массива А, элементами которого являются целые числа. А: _________________[1..100] of ______________.

2. Опишите массив для хранения зарплаты за каждый месяц. Зарплату считать целым числом.

3.Опишите: a)Переменную В для массива, состоящую из 8 символов. b)Переменную MAS для массива, состоящего из 100 вещественных чисел. c)Переменную DAY для массива, состоящего из 30 целых чисел, причем номер первого элемента массива должен быть равен 5

.4. Пусть А : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям: a. Третий элемент массива сделать равным 5. b. Вывести на экран 7-й элемент массива. c. Ввести значение 1-го элемента массива. d. Вычислить сумму 1,2 и 3-го элементов массива.

5. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вычислить сумму всех элементов массива (используйте цикл).

6. Пусть C : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вывести на экран все элементы массива.

7. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Поменять местами первый и последний элементы массива.

8. Пусть В : array [1..20] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Заполнить массив случайными числами из интервала [-24;37].

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".



Вы находитесь на странице вопроса "прочитайте из файла целые числа, увеличьте на 2 и выведите их на экран.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.