Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

В двумерной матрице A(N, M), состоящей из произвольных чисел, определить номера столбцов, в которых среднее арифметическое его элементов меньше чем

10-11 класс

среднее арифметическое элементов массива.

Opana 28 авг. 2013 г., 5:38:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mrrrrrrrrr
28 авг. 2013 г., 6:22:26 (10 лет назад)

var
  i,j,n,m:integer;
  s:real;
  a:array[0..1000,1..1000] of real;
begin
readln(n,m);
randomize;
s:=0;
for i:=1 to n do
  begin
  for j:=1 to m do
        begin
        a[i,j]:=random(10);
        s:=s+a[i,j];
        write(a[i,j],' ')
        end; 
  writeln
  end;
s:=s/n/m;
writeln;
for j:=1 to m do
  begin 
  for i:=1 to n do a[0,j]:=a[0,j]+a[i,j];
  a[0,j]:=a[0,j]/n;
  if a[0,j]<s then write(j,' ')
  end
end.

+ 0 -
Zheka336
28 авг. 2013 г., 8:23:59 (10 лет назад)

var
    i, j, n, m: integer;
    s, t: real;
    a: array[1..100, 1..100] of integer;

begin
    randomize;
   
    readln(n, m);
   
    for i := 1 to n do
    begin
        for j := 1 to m do
        begin
            a[i, j] := random(100);
            s := s + a[i, j];
            write(a[i, j]:3, ' ')
        end;
        writeln()
    end;
   
    s := s / n / m;
   
    writeln();
    for j := 1 to m do
    begin
        t := 0;
        for i := 1 to n do
            t := t + a[i, j];
           
        if t / n < s then
            write(j, ', ')
    end
end.

Ответить

Читайте также

Составить функцию определения факта нахождения в одномерной матрице хоть одного нуля, состоящей из целых чисел и количеством элементов k. применить данную

функцию для нахождения номеров строк, произвольной матрицы, не содержащей нулей. Составить на языке паскаль.

Написать программу на С++. Дана целочисленная квадратная матрица произвольной размерности. Сформировать одномерный массив, в который поместить элементы

двумерной матрицы, находящиеся над побочной диагонали; упорядочить их по возрастанию и найти их среднее арифметическое.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

В одномерном массиве А, состоящем из неповторяющихся чисел с номерами от 1 до N, требуется найти порядковый номер наибольшего отрицательного числа или

установить отсутствие отрицательных чисел. Алгоритм решения задачи записать в виде блок-схемы.



Вы находитесь на странице вопроса "В двумерной матрице A(N, M), состоящей из произвольных чисел, определить номера столбцов, в которых среднее арифметическое его элементов меньше чем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.