Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

ПОМОГИТЕ, ПОЖАЛУЙСТА!!

5-9 класс

Задано трехзначное число. Проверить, что заданное число содержит 3 различных цифры. (Составить программу)

Dysik19 13 нояб. 2015 г., 9:38:26 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alandzagoev19
13 нояб. 2015 г., 10:13:04 (8 лет назад)

var N, c1, c2, c3 : integer;
begin
read(N);
c3:=N mod 10;
N:=N div 10;
c2:=N mod 10;
c1:=N div 10;
if (c1<>c2) and (c1<>c3) and (c2<>c3) then writeln('Содержит')
else writeln('Не содержит');
end.

+ 0 -
Bikmetov1995
13 нояб. 2015 г., 11:37:17 (8 лет назад)

program z;
var n,a,b,c: word;
begin
readln(n);
a:=n mod 10;
n:=n div 10;
b:=n mod 10;
n:=n div 10;
c:=n;
if (a<>b) and (a<>c) and (b<>c) then writeln( 'Число содержит 3 различных цифры') 
else writeln('В числе есть повторяющиеся цифры')
end.

Ответить

Другие вопросы из категории

Информационный объем одного сообщения составляет 0.5 Кбайт, а другого-128 битов. Во сколько раз информационный объем первого сообщения больше объема

второго сообщения?

Информационный объем одного сообщения составляет 0.5 Кбайт, а другого 500 байт. На сколько информационный объем первого сообщения больше объема второго сообщения?

Решите две задачи

Только,пожалуйста,с решением

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "ПОМОГИТЕ, ПОЖАЛУЙСТА!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.