Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

напишите программу, которая вводит два целых числа, a и b (a<b) и выводит на экран 5 случайных целых чисел на отрезке [a;b]

10-11 класс

Nastj2001 05 окт. 2014 г., 11:12:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
111235
05 окт. 2014 г., 13:18:16 (9 лет назад)

var a, b, i, c :integer;
begin
   read (a, b); // вводим a и b 
   for i:=1 to 5 do
   begin
      c:=random(b-a)+a; // присваиваем рандомные числа в заданном промежутке
      writeln (c); // выводим число
   end;
end.

+ 0 -
Kulyebyaka
05 окт. 2014 г., 14:22:01 (9 лет назад)

"вводит два целых числа" с клавиатуры?

+ 0 -
DSD777
05 окт. 2014 г., 15:21:26 (9 лет назад)

наверное

Ответить

Другие вопросы из категории

Докажите ,что : (AvB)->(B->A)=1
Алфавит племени Пиджен состоит из четырех букв. Аборигены закодировали

слово CABD с использованием
следующей кодовой таблицы
Таблица снизу картинка

сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел. получите новый массив, каждый элемент которого равен квадрату

соответствующего элемента исходного массива. в полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива. выведите на экран исходные и полученные результаты

Читайте также

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.



Вы находитесь на странице вопроса "напишите программу, которая вводит два целых числа, a и b (a<b) и выводит на экран 5 случайных целых чисел на отрезке [a;b]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.