Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К

5-9 класс

сожалению, проспать 14 часов ему не удалось, т.к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит.
Входные данные: Два целых числа S и T(1 < S < 24, T < 12) - час, когда исследователь лег спать, и час, на который он установил будильник.
Выходные данные: Целое число - через сколько часов зазвонит будильник.

Gigi1 02 янв. 2017 г., 15:07:39 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mara771
02 янв. 2017 г., 17:35:51 (7 лет назад)

program gt;
var k,s,t:integer;
begin
read(s,t);
if(s<=12)then begin
if(s<=t)then k:=t-s;
if(s>t)then k:=t+12-s;
end;
if(s>12)then begin
if(s<=t+12)then k:=t+12-s;
if(s>t+12)then k:=24-s+t;
end;
writeln(k);
end.

+ 0 -
наги0644
02 янв. 2017 г., 18:27:51 (7 лет назад)

VB.

Dim S As Integer ' 1<=S<=24
Dim T As Integer ' T<=12       
S = InputBox("S=")       
T = InputBox("T=")       

Select Case S
  Case Is <= T
                MsgBox(T - S)
   Case Is > T
                If T = 12 Then MsgBox((T + 12) - S) Else MsgBox(24 - (S - T))       
End Select

Ответить

Другие вопросы из категории

НЕ ((Пер­вая буква со­глас­ная) И (По­след­няя буква глас­ная))?

1) Дарья
2) Павел
3) Абрам
4) Ан­фи­са

Читайте также

Помогите написать программу по Паскалю,пожалуйста.

Известно, что коды прописных (заглавных) букв латинского алфавита следуют в таблице непрерывно друг за другом. Коды строчных букв латиницы также следуют непрерывно друг за другом на расстоянии 32 символов от прописных (ниже по таблице) .

Если ord('A') = 65, то ord('A')+32 = 97, и это код строчной буквы «а» , то есть chr(ord('A')+32) = 'а'.

Помогите сделать задачу в Excel по теме работа с различными функциями От железнодорожной станции по направлению к дачному

поселку (расстояние между ними 2000) движется пешеход со скоростью 5 км/ч. Одновременно с ним в
том же направлении бежит собака, со скоростью 10 км/ч. Поскольку собака
бежит быстрее, то, добежав до дома и
радостно известив о приближении хозяина, она разворачивается и бежит к
человеку, а от него обратно к дому т.д. Какой суммарный путь пробежит собака за
время, пока человек дойдет до дома?

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

Пятеро одноклассников: Аня, Саша, Лена, Вася и Миша стали победителями олимпиад школьников по истории, математике, информатике, литературе и географии.

Известно, что:
1) победитель олимпиады по информатике учит Аню и Сашу работе на компьютере;
2) Лена и Вася тоже заинтересовались информатикой;
3) Саша всегда побаивался истории;
4) Лена, Саша и победитель олимпиады по литературе занимаются плаванием;
5) Саша и Лена поздравили победителя олимпиады по математике;
6) Аня сожалеет о том, что у нее остается мало времени на литературу.
Победителем какой олимпиады стал каждый из этих ребят?



Вы находитесь на странице вопроса "Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.