Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Нужна помощь, буду очень благодарен.

10-11 класс

Создайте файл f, компоненты которого являются действительными числами. Напишите программу вычисления суммы компонентов файла f и произведения ненулевых компонентов этого файла.
Язык программирования: Pascal

Chmolyha 16 июля 2016 г., 6:54:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aannabarmin
16 июля 2016 г., 9:52:52 (7 лет назад)

uses crt;
var f:text;
    i,x,sm,n:integer;
    pr:longint;
begin
randomize;
clrscr;
pr:=1;
assign(f,'f.txt'); rewrite(f);
writeln('Введите число заполнений (например 6, в файле будет шесть натуральных чисел) ?'); readln(n);
for i:=1 to n do
begin
write(i,') ');
readln(x);
writeln(f,x);
end;
close(f);

+ 0 -
Lednevsasha9
16 июля 2016 г., 10:56:48 (7 лет назад)

cvar
  f: Text;
  k: integer;
  s, p: longint;
  i: integer;

begin
  Assign(f, 'output.dat');
  Rewrite(f);
  writeln('Вводите данные, окончание число 7777');
  repeat
    read(k);
    if k<>7777 then writeln(f,k)
    until k=7777;
  Close(f);
  Reset(f);
  s := 0;
  p := 1;
  writeln;
  while not Eof(f) do
  begin
    readln(f, k);
    write(k:4);
    s := s + k;
    if k <> 0 then p := p * k
  end;
  Close(f);
  writeln;
  writeln('Сумма= ', s, ', произведение= ', p)
end.

Вводите данные, окончание число 7777
3
6
-4
6
2
-3
-4
2
6
0
5
-1
7777

   3   6  -4   6   2  -3  -4   2   6   0   5  -1
Сумма= 18, произведение= 622080



+ 0 -
Lecher
16 июля 2016 г., 12:48:43 (7 лет назад)

а в файл вносим случайные числа?

+ 0 -
Lolaprotopop
16 июля 2016 г., 13:28:42 (7 лет назад)

Нет, числа забивать вручную

Ответить

Другие вопросы из категории

ПаскальАВС.


№1. Вычислить сумму и число положительных элементов матрица А[N,N], находящихся над главной диагональю.
№2. Дана вещественная матрица А размера n x m. Определить k - количество "особых" элементов массива А, считая его элемент особым, если он больше суммы остальных элементов его столбца.

Читайте также

Здравствуйте, нужна помощь, буду очень благодарна! "С клавиатуры считываются числа, отличные от нуля. Создайте два списка, один из которых состоит из от

рицательных чисел, а другой - из положительных" Тема "Односвязные списки". Заранее спасибо!

Ребята, помогите срочно!!!!) завтра экзамен, и надо принести домашнюю работу.....нужно написать программку в Delphi. вот задание...."Дана

строка, содержащая не более двадцати латинских букв. Все вхождение «max» в ней заменить на «min» и «макс» на «мин». Подсчитать число таких замен." Буду очень благодарен, если кто поможет. прикрепляю так же образец, как именно должен выглядеть код программы. Заранее всем кто поможет огромное СПАСИБО!!!!!!!!!!

Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму

всех чисел, расположенных после первого нулевого элемента.
Написать на Паскале буду очень благодарен!!



Вы находитесь на странице вопроса "Нужна помощь, буду очень благодарен.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.