Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите сделать в паскале! Дан массив, содержащий 70 целых чисел. Опишите на одном из языков

10-11 класс

программирования эффективный алгоритм, позволяющий найти и вывести наибольшую
разность двух чисел, содержащихся в массиве.

KacTTep 18 окт. 2014 г., 15:04:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iulii
18 окт. 2014 г., 15:56:04 (9 лет назад)

var
  i,min,max:integer;
  a:array[1..70]of integer;
begin
for i:=1 to 70 do
  begin
  a[i]:=random(100);
  write(a[i],' ');
  if i=1 then min:=a[i]
    else if a[i]<min then min:=a[i];
  if a[i]>max then max:=a[i];
  end;
writeln;
writeln('Ответ: ',max-min);
end.

Ответить

Другие вопросы из категории

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

1) Дан целочисленный массив из 30 элементов.

Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного
класса. В баскетбольную команду берут тех, чей рост не менее 180 см. Опишите на
русском языке или на одном из языков программирования алгоритм, который подсчитывает
и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что
хотя бы один ученик играет в баскетбольной команде. Исходные данные объявлены
так, как показано ниже. Использовать другие переменные запрещается.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, позволяющий найти и вывести сумму элементов массива, кратных тринадцати. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого делится на тринадцать. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.


const N=30;
var a: array [l..N] of integer;
i,j,s: integer;
begin
for i:=l to N do readln(a[i]);
...
end.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от –1000 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, который находит и выводит среднее арифметическое всех элементов массива, оканчивающихся цифрой 5. Гарантируется, что хотя бы один такое элемент в массиве есть.

НАРОД ПОМОГИТЕ ПОЖАЛУЙСТА



Вы находитесь на странице вопроса "помогите сделать в паскале! Дан массив, содержащий 70 целых чисел. Опишите на одном из языков", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.