Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составьте алгоритм определения числа дней между двумя датами и нарисуйте блок-схему.

10-11 класс

хасаньчик 28 дек. 2014 г., 5:07:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olgamariupol
28 дек. 2014 г., 6:01:40 (9 лет назад)

function NumDaY(DD,MM,YYYY:integer):long;

begin

if YYYY/4=YYYY\4 then

m=[31,29,31,30,31,30,31,31,30,31,30,31]

else

m=[31,28,31,30,31,30,31,31,30,31,30,31]

endif;

 

for i=1 to MM-1 do

DD_t=dd_t+m[i]

end;

if YYYY>=0 then

for i=1 to YYYY do begin

if YYYY/4<>YYYY\4 then

DD_T=DD_t+365

else

DD_t=DD_t+366

end;

else

for i=1 to YYYY do begin

if YYYY/4<>YYYY\4 then

DD_T=DD_t-365

else

DD_t=DD_t-366

end;

endif

end;

 

begin

readln(DD1,MM1,YYYY1);

readln(DD2,MM2,YYYY2);

res=NumDay(DD2,MM2,YYYY2)-NumDay(DD1,MM1,YYYY1)

writeln(Res)

end.

 

Пояснение - вычисляем порядковый номер дня по дате, разница в днях определяется как разница номеров.

Ответить

Читайте также

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

помогите пожалуйста сделать тест

Тестовые вопросы
К чему приводит нажатие клавиши «Tab» при вводе текста?
а) переводит курсор в следующую ячейку по строке;
б) переводит курсор в следующую ячейку по столбцу;
в) возвращает курсор на одну ячейку назад по строке.
2. Адрес ячейки – это:
а) элемент формулы, содержащий данные, которые необходимо выполнить;
б) название столбца и номер строки, записанные в поле имен;
в) номер столбца.
3. С помощью какой формулы можно вычислить в ячейке С1 разность между двумя
датами, выраженную в количестве дней без учета лет и месяцев?
а) =РАЗНДАТ(A1;B1;"D»);
б) =РАЗНДАТ(A1;B1;"MD»);
в) =РАЗНДАТ(A1;СЕГОДНЯ();"Y»).
4. Укажите команды, которые позволяют выделить ячейки Excel подобным
образом, как изображено на рисунке.
а) Формат ячеек - Граница - Цвет;
б) Формат ячеек - Заливка - Цвет узора - Узор;
в) Сортировка - Настраиваемая сортировка.
5. Для копирования форматирования одной ячейки в другую используется кнопка:
а) Формат по образцу;
б) Копировать;
в) Вырезать.
6. На какой вкладке ленты главного меню располагается функция, позволяющая
построить диаграмму по заданным в ячейках параметрам?
а) Главная;
б) Вставка;
в) Разметка страницы;
г) Формулы;
д) Данные.
7. Укажите результат, который получится в ячейке В11, изображенной на рисунке
после того, как в нее вести формулу и нажать кнопку «Enter».
а) 214, 208;
б) 240,008;
в) 244, 568;
г) правильного ответа нет.
8. Что является основным элементом рабочего листа в Excel?
а) столбец;
б) строка;
в) ячейка;
г) таблица.
9. Диапазон – это:
а) все ячейки одной строки;
б) совокупность клеток, образующих в таблице область прямоугольной формы;
в) все ячейки одного столбца;
г) множество допустимых значений.
10. В электронной таблице выделена группа ячеек А1:С6. Сколько ячеек входит в
этот диапазон?
а) 3;
б) 6;
в) 12;
г) 18.
11. Активная ячейка – это ячейка:
а) для записи команд;
б) содержащая формулу, включающую в себя имя ячейки, в которой выполняется
ввод данных;
в) в которой находится формула с указанием ссылки на содержание зависимой
ячейки;
г) в которой выполняется ввод данных.
12. При помощи какой вкладки строки меню устанавливается разрешение переноса
информации в ячейке по словам?
а) Главная;
б) Вставка;
в) Данные;
г) Формулы.
13. С чего должна начинаться любая формула в Microsoft Excel?
а) со слова «равно»;
б) со знака «=»;
в) со знака скобок «( )».
14. Упорядочивание значений диапазона ячеек в определенной
последовательности называют:
а) фильтрацией;
б) форматированием;
в) группировкой;
г) сортировкой.

Помогите пожалуйста ))СоставитьПомогите пожалуйста ))Составить программу по которой проверяют является ли элемент массива четным числом.Для записи

"делятся на"использовать стандартную функцию MOD,которая определяет остаток отделение числа А на число В.Примечание таблица R целочисленная.Построение блок-схемы,алгоритм и бейсики.Заранее большое спасибо))

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.



Вы находитесь на странице вопроса "Составьте алгоритм определения числа дней между двумя датами и нарисуйте блок-схему.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.