Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составьте алгоритм упорядочения значения трех переменных по возрастанию, т.е. при любых исходных значениях А, В и С, отсортируйте их так, чтобы стало

5-9 класс

А<В<С.
На паскале программу напишите)

Elena1234lena 03 сент. 2013 г., 14:23:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
умник1111
03 сент. 2013 г., 16:51:15 (10 лет назад)

procedure swap(var a, b: real);
var t: real;
begin
     t := a;
     a := b;
     b := t;
end;

var a, b, c: real;
begin
     readln(a, b, c);
     if (a > b) then swap(a, b);
     if (b > c) then swap(b, c);
     if (a > b) then swap(a, b);
     writeln(a, ' ', b, ' ', c);
end.
===========================
Без процедур:

var a, b, c, t: integer;
begin
     readln(a, b, c);
     if (a > b) then
     begin
          t := a;
          a := b;
          b := t;
     end;
     if (b > c) then
     begin
          t := b;
          b := c;
          c := t;
     end;
     if (a > b) then
     begin
          t := a;
          a := b;
          b := t;
     end;
     writeln(a, ' ', b, ' ', c);
end.

+ 0 -
BURATO
03 сент. 2013 г., 17:57:10 (10 лет назад)

Искал в архиве, накнулся на твой вопрос :-) Приветствую тебя, коллега!

Ответить

Другие вопросы из категории

пожалуйста , срочно нужно!
У исполнителя Утроитель две команды , которым присвоены номера:

1.вычти один
2.умножь на три
Первая из них уменьшает число на экране на 1, вторая - утраивает его .
Запишите порядок команд в алгоритме получения числа 5 числа 26, содержащем не более 5 команд, указывая лишь номера команд (
Например, 21211 - это алгоритм :
умножь на три
вычти один
умножь на три
вычти один
вычти один
который преобразует число 2 в 13)
Если таких алгоритмов больше одного, то напишите любой из них

Читайте также

1) Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную? К каким последствиям это может

привести?

2) Напишите на АЯ алгоритм сложения двух простых дробей(без сокращения дроби)

3) Напишите на АЯ алгоритм вычисления Y по формуле: y=(1-x2+5x^4)^2, где x- заданное целое число. Учтите следующие ограничения: 1) В арифметических выражениях можно использовать только операции сложения, вычитания и умножения. 2) Выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при x=2.

4) Пользуясь ограничениями предыдущей задачи, напишите наиболее короткие алгоритмы вычисления выражений: y=x^8, y=x^10, y=x^15, y=x^19. Выполните трассировку алгоритмов.

5) Запишите алгоритм циклического обмена значениями трех переменных A,B,C. Схема циклического обмена:

a-->b-->c(стрелочка C к A сверху)

Например, если до обмена было: A=1,B=2,C=3, то после обмена должно стать: A=3,B=1,C=2. Выполните трассировку.

Запишите алгоритм циклического обмена значениями трех переменных a,b.c. Схема циклического обмена a->b->c Например, если до обмена было

a=1,b=2,c=3, то после обмена должно стать a=3,b=1,c=2. Выполнить трассировку.

Алгоритм: Трассировочная таблица:



Вы находитесь на странице вопроса "Составьте алгоритм упорядочения значения трех переменных по возрастанию, т.е. при любых исходных значениях А, В и С, отсортируйте их так, чтобы стало", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.