Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

program vst; var

10-11 класс

c:

Fjhvgff 25 июня 2013 г., 12:15:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nora76
25 июня 2013 г., 13:30:08 (10 лет назад)

Чтобы массив заполнялся от -15 до 20:

program vst;
var c:array [0..100] of integer;
j,n,k,i:integer;
min:integer;
begin
randomize; writeln('n='); read(n);
for i:=1 to n do c[i]:=random(36)-15;
writeln;
for i:=1 to n do write (c[i],' ');
min:=c[1];
for i:=2 to n do
if min>c[i] then min:=c[i];
writeln ('min=',min);
writeln('k='); read(k);
for i:=n+1 downto k do c[i]:=c[i-1];
c[k]:=min;
writeln; for i:=1 to n+1 do write (c[i],' ');
end.

---

Чтобы был ручной ввод:

program vst;
var c:array [0..100] of integer;
j,n,k,i:integer;
min:integer;
begin
writeln('n='); read(n);
for i:=1 to n do
readln(c[i]);
writeln;
for i:=1 to n do write (c[i],' ');
min:=c[1];
for i:=2 to n do
if min>c[i] then min:=c[i];
writeln ('min=',min);
writeln('k='); read(k);
for i:=n+1 downto k do c[i]:=c[i-1];
c[k]:=min;
writeln; for i:=1 to n+1 do write (c[i],' ');
end.

+ 0 -
Mashkaaaaaaa
25 июня 2013 г., 15:49:39 (10 лет назад)

Program vst;
var
  c:array [0..100] of integer;
  j,n,k,i:integer;
  min:integer;
begin
  randomize; write('Введите N = '); readln(n);
  for i:=1 to n do
    c[i]:=random(36)-15;
  writeln;
  for i:=1 to n do
    write (c[i],' ');
  writeln;
  min:=c[1];
  for i:=2 to n do
    if min>c[i] then min:=c[i];
  writeln ('min = ',min);
  write('Введите место для вставки минимального элемента К = '); readln(k);
  writeln ('Вывод массива:');
  write('Было:  ');
  for i:=1 to n do
    write (c[i]:3,' ');
  for i:=n+1 downto k do
    c[i]:=c[i-1];
  c[k]:=min;
  writeln;
  write('Стало: ');
  for i:=1 to n+1 do
    write (c[i]:3,' ');
end.

Ответить

Другие вопросы из категории

ДАМ 22 ПУНКТА СРОЧНО

СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ
данны два числа a и b.составить программу для вычисления среднего арифметического кубоы этих чисел

Читайте также

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.

Помогите составить блок схему к задачи Pascal

program sdasdas;
var
a:array [1..10] of integer;
p,i:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(495)+5;
p:=1;
begin
for i:=1 to 10 do
if (a[i] mod 3=0) or (a[i] mod 9=0) then p:=p*a[i];
writeln('Произведение =',p);
end;
readln;
end.

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.

Приветик, написала программу, помогите плиз сделать форматированный вывод, так чтобы все значения X были напсаныв первой строчке,значения sin во

второй, а tg на третьей строчки

program h;

var f:text;

x,y,z:real;

begin

assign (f,'c:\ty.txt');

reset (f);

rewrite(f);

x:=0;

while x<=3 do

begin

x:=x+0.1;

y:=sin(x);

z:=sin(x)/cos(x);

write(f,' x= ',x:4:2,' ');

write(f,'sin ',y:7:5, ' ');

write(f,'tg ',z:5:3,' ');

end;

close(f);

end.

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.



Вы находитесь на странице вопроса "program vst; var", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.