Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Какова траектория исполнителя Муравей после выполнения последовательности

10-11 класс

команд: вперед (1см), направо (90о), вперед (1 см), направо
(90о), вперед (1см), направо (90о), вперед (1 см), направо
(90о)?



Определите значение переменной a после
выполнения фрагмента алгоритма:

Примечание: знаком := обозначена
операция присваивания.

Glazkovaoa 13 мая 2015 г., 21:02:24 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jgxhxzd
13 мая 2015 г., 22:15:02 (8 лет назад)

В 1задании траектория в виде квадрата(вар.3).
Во 2задании a=16, b=4.

Ответить

Другие вопросы из категории

Придумать слово из 9 букв
Ребят, объясните как сделать гиперссылку в презентации на другой слайд. Поясняю есть презентация, в ней 5 слайдов, первый слайд-это содержание, и мне нужно

сделать гиперссылку на другие 4 слайда из этого содержания. Помогите пожалуйста.

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо

Читайте также

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

а)Для кодирования 300 различных сообщений используют 5 последовательных цветовых вспышек .Лампочки скольких различных цветов должны использоваться при

передаче? б)Дан фргмент электронной таблица:Какое число должно быть записано в ячейкеВ1 ,чтобы построенная после выполнения вычеслений диаграмма по значениям диапозона ячеек А2:Д2 соответствовало рисунку

1 .Электронный почтовый ящик имеет объем 1 Мбайт. Информация на его адрес по открытому на прием каналу связи передается со скоростью 128 Кбайт/ мин.

Через какое время у поставщика услуг электронной почты появится повод прислать извещение о переполнении почтового ящика?

2.В мешке лежит 256 красных яблок.
Сколько информации содержит сообщение, что достали красное яблоко
(Объясните Ваш ответ)

3. Каково будет значение переменной X после выполнения операций присваивания?

X=2
Y=4
Y=X*X+X
X=Y*Y-X*X
Заранее спасибо=)

каковы будут значения переменных a и b после выполнения операций присваивания (начальное значение а=5)?

а:=a+1;
b:=sqr(a);
a:=sqrt(b)+a;

пожалуйста с подробным решением...



Вы находитесь на странице вопроса "Какова траектория исполнителя Муравей после выполнения последовательности", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.