Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заменить отрицательные элементы массива М(30) в ячейках, номера которых кратны 5, их квадратам. очень срочно, помогите.

10-11 класс

Zukiv 08 дек. 2016 г., 2:08:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KIRILL567
08 дек. 2016 г., 2:59:51 (7 лет назад)

const n=30;
var m:array[1..n] of integer;
i:integer;
begin
for i:=1 to n do m[i]:=random(20)-10;
for i:=1 to n do write(m[i]:5);
writeln;
for i:=1 to n do
if (m[i]<0) and (i mod 5=0) then
m[i]:=sqr(m[i]);
for i:=1 to n do write(m[i]:5);
end.

Ответить

Другие вопросы из категории

напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность

символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Строка S не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

скласти програму привітання з ПК,у вікні виконання матимемо:

привіт,я ПК
як тебе звати?
(імя)
(імя),мені дуже приємно з вами познайомитися

информация представленная в компьютерной форме и обрабатываемая на компьютере называется?

а)программной
б) данными
в)набором команд
с) результатом

Читайте также

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, позволяющий найти и вывести сумму элементов массива, кратных тринадцати. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого делится на тринадцать. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.


const N=30;
var a: array [l..N] of integer;
i,j,s: integer;
begin
for i:=l to N do readln(a[i]);
...
end.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5



Вы находитесь на странице вопроса "Заменить отрицательные элементы массива М(30) в ячейках, номера которых кратны 5, их квадратам. очень срочно, помогите.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.