Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Запишите алгоритм циклического обмена значениями трех переменных a,b.c. Схема циклического обмена a->b->c Например, если до обмена было

5-9 класс

a=1,b=2,c=3, то после обмена должно стать a=3,b=1,c=2. Выполнить трассировку.

Алгоритм: Трассировочная таблица:

KirillSpilBerg 20 нояб. 2013 г., 18:36:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natabersteneva
20 нояб. 2013 г., 19:49:41 (10 лет назад)

var a,b,c,t:integer;

Begin

  read(a,b,c);

  t:=a;

  a:=c;

  c:=b;

  b:=t;

  writeln(a,b,c);

End.

Ответить

Читайте также

1) Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную? К каким последствиям это может

привести?

2) Напишите на АЯ алгоритм сложения двух простых дробей(без сокращения дроби)

3) Напишите на АЯ алгоритм вычисления Y по формуле: y=(1-x2+5x^4)^2, где x- заданное целое число. Учтите следующие ограничения: 1) В арифметических выражениях можно использовать только операции сложения, вычитания и умножения. 2) Выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при x=2.

4) Пользуясь ограничениями предыдущей задачи, напишите наиболее короткие алгоритмы вычисления выражений: y=x^8, y=x^10, y=x^15, y=x^19. Выполните трассировку алгоритмов.

5) Запишите алгоритм циклического обмена значениями трех переменных A,B,C. Схема циклического обмена:

a-->b-->c(стрелочка C к A сверху)

Например, если до обмена было: A=1,B=2,C=3, то после обмена должно стать: A=3,B=1,C=2. Выполните трассировку.

Запишите на языке Паскаль программу циклического обмена значениями трёх переменных

a,b,c.

Схема циклического обмена:

a <- b <- c

I ^

I I

v--------->

Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

Пароль от почтового ящика в виде четырехзначного числа Вася

зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов
ведется вправо налево начиная с нуля), циклически сдвигаются вправо, а
нечетные-влево на количество позиций, равных номеру разряда. Так,
например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1
(7->8->9->0->1). Затем из нечётных цифр вычитается, а к
чётным прибавляется 1. Далее оба шага повторяется еще один раз. В
результате шифровки получилось число 3216. Определите пароль.

Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов ведется вправо налево

начиная с нуля), циклически сдвигаются вправо, а нечетные-влево на количество позиций, равных номеру разряда. Так, например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1 (7->8->9->0->1). Затем из нечётных цифр вычитается, а к чётным прибавляется 1. Далее оба шага повторяется еще один раз. В результате шифровки получилось число 3216. Определите пароль.

Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов ведется вправо

налево начиная с нуля), циклически сдвигаются вправо, а нечетные-влево на количество позиций, равных номеру разряда. Так, например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1 (7->8->9->0->1). Затем из нечётных цифр вычитается, а к чётным прибавляется 1. Далее оба шага повторяется еще один раз. В результате шифровки получилось число 3216. Определите пароль.



Вы находитесь на странице вопроса "Запишите алгоритм циклического обмена значениями трех переменных a,b.c. Схема циклического обмена a-&gt;b-&gt;c Например, если до обмена было", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.