Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дана последовательность чисел a1, a2, …, an. Требуется переставит числа в поряд-ке возрастания. Для этого сравниваются два соседних числа ai и ai+1. Если

10-11 класс

ai>ai+1 то делается пере-становка. Так продолжается до тех пор, пока все элементы не станут расположены в порядке воз-растания. Составить алгоритм сортировки, подсчитывая при этом количество перестановок.
ПОМОГИТЕ СДЕЛАТЬ В ПАСКАЛЬ, ПРОШУ =*(

Nadejdaartem 07 февр. 2014 г., 21:38:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Se0x
07 февр. 2014 г., 23:14:58 (10 лет назад)

const
max = 10000;
var i, j : Integer;
x,raz : LongInt;
A : array[0..max] of LongInt;   
BEGIN
// 
//Допустим уже массив заполнен
//
    
  for i := max downto 2 do        
for j := 2 to i do          
if A[j] < A[j - 1] then            
begin              
 x := A[j];              
 A[j] := A[j - 1];              
 A[j - 1] := x;
inc(raz);            
end;  
writeln('Количество перестановок = ', raz); 
END.
Не проверял, но должно вроде бы работать:)

+ 0 -
Ksushakisaromanova
08 февр. 2014 г., 0:34:45 (10 лет назад)

Комментарий удален

+ 0 -
Yagodka176
08 февр. 2014 г., 3:02:41 (10 лет назад)

Комментарий удален

+ 0 -
Nastyavladimir1
08 февр. 2014 г., 5:44:37 (10 лет назад)

Составить программу для решения следующей задачи: Дан массив С(10). Сформируйте из него массив А, предварительно определив его длину, включая в массив А четные положительные элементы. А для этой?)))

+ 0 -
Oms20
08 февр. 2014 г., 6:19:53 (10 лет назад)

Комментарий удален

+ 0 -
Katena96423157
08 февр. 2014 г., 7:28:47 (10 лет назад)

думаю нет

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА УМОЛЯЮ

.Получить
двоичный код из вещественного числа 0.125

Как изменится формула =2*А2+$В4-3*$А&6, находящийся в ячейке табличного процессора при копировании ее в ячейку на 2 позиции правее и на 3 позиции вниз

от текущей? Выберете верный ответ.
а) =2*А2+$В7-3*$А$6 б) =2*С5+$В10-3*$А$6 в) =2*С5+$В7-3*$А$6 г) =2*С5+$В7-3*$С$6
Помогите, пожалуйста с:

1.При угадывании целого числа в диапазоне от 1 до N было получено 7 бит информации. Чему равно N? 2. При угадывании целого числа в некотором

диапазоне было получено 6 бит информации. Сколько чисел содержит этот диапазон?

тут две задачи. но они подобные.

умоляю!!! решите!! низнаю как!!!

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА! ОЧЕНЬ НУЖНО!( 1)Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну

позицию, то есть получите вектор А = (a2 , a3 , ..., aN , a1 ).

2) Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.

СИ++. #include <stdio.h>

#include <conio.h>

Дано n, . Вычислить: a1 - a2 + a3- …+ (-1)n+1 an. Дано n, . Получить последовательность , где b1

= a1, b2 = a1+ a2, …, bn = a1+ an. Дано n. Получить последовательность , где Даны n,. Получить сумму и количество тех элементов данной последовательности, которые кратны 5 и не кратны 4. Даны n,. Вычислить Даны n и . Получить a1, a2, …, an , 2a1, 3a2, …, (n + 1)n an. Выяснить образуют ли они возрастающую последовательность.

Задача F Оплата Сегодня Али в местном магазине сделал покупку за C тенге. Он только хотел расплатится и услышал от прод

авца фразу "Без сдачи пожалуйста, молодой человек". У него есть всего N монет достоинств a1, a2, ..., aN тенге. Определите, сможет ли он расплатится без сдачи.

Формат входных данных

В первой строке входного файла записаны два целых числа C (1 ≤ C ≤ 1000) и N (1 ≤ N ≤ 15) — общая сумма покупки и количство монет у Али соответсвенно. Во второй строке записаны N целых чисел a1, a2, ..., aN (1 ≤ ai ≤ 1000)— достоинства монет Али.

Формат выходных данных

В единственной строке выведите слово «YES», если Али сможет расплатится без сдачи. Иначе, выведите «NO»



Вы находитесь на странице вопроса "Дана последовательность чисел a1, a2, …, an. Требуется переставит числа в поряд-ке возрастания. Для этого сравниваются два соседних числа ai и ai+1. Если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.