Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

народ мне срочно нужно написать программу на языке паскаль

5-9 класс

суть программы вычислять по ответам на вопросы (да,нет) есть ли у вас игровая зависимость,
Вопросы:
1 В день вы играете более 2-ух часов?
2 Становитесь ли вы раздражительным после игры?
3 Из-за компьютерной игры вы пренебрегает сном?
4 Для игры в компьютерные игры вы жертвует временем, ранее проводимым с семьёй, друзьями?
5 вы приобретаете проблемы в учёбе, на работе из-за компьютерной игры но продолжаете в неё играть?
6 После компьютерной игры у вас возникает сухость слизистых глаз?
7 Человек испытывает потребность проводить за игрой всё больше времени?
8 Из-за компьютерной игры человек пренебрегает личной гигиеной?
9 Во время компьютерной игры человек полностью отрешается от реальной действительности, переносясь целиком в мир игры




народ кароче если в ответах да повторяется более чем 2 раза то программа должна вывести "есть вероятность что у вас есть игровая зависимость"
если нет то "пока вам не стоит беспокоиться"\



за ранние огромное спасибо

Викори 12 окт. 2014 г., 13:58:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BillboarD
12 окт. 2014 г., 16:50:32 (9 лет назад)

program zadrotTester;
Var a:array [0..9] of byte;
sum,i:byte;
begin
Writeln('1 - да     0 - нет');
Writeln('В день вы играете более 2-ух часов? ')'
read(a[1]);
Writeln(' Становитесь ли вы раздражительным после игры?')'
read(a[2]);
Writeln(' Из-за компьютерной игры вы пренебрегает сном?')'
read(a[3]);
Writeln(' Для игры в компьютерные игры вы жертвует временем, ранее проводимым с семьёй, друзьями?')'
read(a[4]);
Writeln(' вы приобретаете проблемы в учёбе, на работе из-за компьютерной игры но продолжаете в неё играть?')'
read(a[5]);
Writeln('После компьютерной игры у вас возникает сухость слизистых глаз?')'
read(a[6]);
Writeln('Человек испытывает потребность проводить за игрой всё больше времени?')'
read(a[7]);
Writeln(' Из-за компьютерной игры человек пренебрегает личной гигиеной?')'
read(a[8]);
Writeln('Во время компьютерной игры человек полностью отрешается от реальной действительности, переносясь целиком в мир игры?')'
read(a[9]);
sum:=0
for i:=1 to 9 d0
sum:=a[i];
If sum>2 then writeln('есть вероятность что у вас есть игровая зависимость') else writeln('пока вам не стоит беспокоиться

Ответить

Читайте также

Нужно написать программу на языке Паскаля!

Вот задача:
Найти сумму цифр данного числа

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Написать программу на языке программирования Pascal.

Перевод дюймов в сантиметры (1дюйм=2,54см). Нужно, чтобы при запуске программы на экране выходило в два столбика дюймы и сколько это будет сантиметров. До 20 чисел. Через оператор While.

Составить программу на языке Паскаль y=x+2x( х в квадрате)+c

Срочно нужна помощь!



Вы находитесь на странице вопроса "народ мне срочно нужно написать программу на языке паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.