Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1). реализуйте решение задачи, программируя на Паскале. Единицы массы пронумерованы следующим образом : 1 - килограмм, 2 - миллиграмм, 3 - грамм,

5-9 класс

4 - тонна. Дан номер елиницы массы и масса тела М в жтих единицах (М-вещественное число). Вывести массу данного тела в киллограммах.

Зояла 05 сент. 2013 г., 16:04:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DaLaMaR
05 сент. 2013 г., 18:41:23 (10 лет назад)

var n,x:integer;
    m:real;
begin
writeln('Введите единицу массы');
read (n);
writeln('Введите массу');
read (m);
if (n<1) or (n>4) then
writeln('ОШИБКА');
if n = 1 then
write (m,' кг');
if n = 2 then
begin
m:=m/1000/1000;
write (m,' кг');
end;
if n = 3 then
begin
m:=m/1000;
write (m,' кг');
end;
if n = 4 then
begin
m:=m*1000;
write (m,' кг');
end;
end.

Ответить

Другие вопросы из категории

Если во время работы OC WINDOWS одновременно открыто пять окон,то как определить,какое окно активное?

1.его заголовок выделен цветом
2.оно самое большое
3.в нём расположен указатель мыши.

2. Какие двоичные числа соответствуют следующим десятичным числам:

128; 256; 512; 1024?
3. Чему в десятичной системе равны следующие двоичные числа:
1000001; 10000001; 100000001; 1000000001?
4. Переведите в десятичную систему следующие двоичные числа:
101; 11101; 101010; 100011; 10110111011.
5. Переведите в двоичную систему счисления следующие десятичные числа:
2; 7; 17; 68; 315; 765; 2047.
6. Выполните сложение в двоичной системе счисления:
11 + 1; 111 + 1; 1111 + 1; 11111 + 1.
7. Выполните умножение в двоичной системе счисления:
111 · 10; 111 · 11; 1101 · 101; 1101 · 1000.

Помогите, пожалуйста, решить задачу на паскале. Срочно.

Даны два натуральных числа m и n. (m,n ≤ 9999). Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n.

Сформируйте массив bc размерностью30 элементов случайным образом из диапазона 0 – 50.сформированный массив выведите на экран в строку. Подсчитайте

сумму всех четных элементов массива и отдельно сумму элементов имеющих четные индексы. Выведите результаты подсчета на экран. Отсортируйте данный массив по убыванию.

Читайте также

реализуйте решение задачи, программируя на Паскале. Программа морскрй бой. Учитель задумывает два числа от 0 до 9. (Водятся учителемв Вашу программу). И

грок пытается их угадать, вводя свои числа. Если они совпали(в указанном порядке), то игрок выиграл (выводится сообщение-"попал"). Иначе-сообщение "мимо".

реализуйте решение задачи, программируя на Паскале. Программа морскрй бой. Учитель задумывает два числа от 0 до 9. (Водятся учителемв Вашу программу). И

грок пытается их угадать, вводя свои числа. Если они совпали(в указанном порядке), то игрок выиграл (выводится сообщение-"попал"). Иначе-сообщение "мимо".

Задача на паскале Задан массив А размерности N случайным образом.

Нужно сформировать новый массив по следующему правилу:
все чётные элементы разделить на 2, все нечётные оставить без изменения

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

1. Как называется свойство алгоритма,1. Как называется свойство алгоритма, означающее, что данный алгоритм применим к решению целого класса задач?

а) понятность
б) определённость
в) результативность
г) массовость
2. Как называется свойство алгоритма, означающее, что он всегда приводит к результату через конечное, возможно, очень большое число шагов?
а) дискретность
б) понятность
в) результативность
г) массовость
3. Как называется свойство алгоритма, означающее, что он задан с помощью таких предписаний, которые исполнитель может воспринимать и по которым может выполнять требуемые действия?
а) дискретность
б) понятность
в) определённость
г) массовость
4. Как называется свойство алгоритма, означающее, что пусть решения задачи разделён на отдельные шаги?
а) дискретность
б) определённость
в) результативность
г) массовость
5. Как называется свойство алгоритма, означающее, что путь решения задачи определён вполне однозначно, на любом шаге не допускаются никакие двусмысленные и недомолвки?
а) дискретность
б) понятность
в) определённость
г) результативность



Вы находитесь на странице вопроса "1). реализуйте решение задачи, программируя на Паскале. Единицы массы пронумерованы следующим образом : 1 - килограмм, 2 - миллиграмм, 3 - грамм,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.