Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

в массиве хранится информация о количестве осадков(целые числа),выпавших за каждый день прошедшей недели.Вывести номера дней,когда осадков не было

10-11 класс

Nikita211 25 сент. 2013 г., 11:46:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MishaGizenko
25 сент. 2013 г., 14:02:05 (10 лет назад)

uses crt;
var i:integer;
a:array[1..7] of integer;
begin
for i:=1 to 7 do begin
a[i]:=random(10);
write(a[i]:3);
end;
writeln;
write('Номера дней, в которые не было осадков: ');
for i:=1 to 7 do begin
if a[i]=0 then write(i:2);
end;
writeln;
end.

Здесь количество осадков - случайная цифра от 0 до 9. Если нужно сделать ввод чисел вместо случайных, вместо строчки  a[i]:=random(10); пишем read(a[i]);

 

Ответить

Другие вопросы из категории

Решить задачу.Паскаль.

Дан двумерный массив.в квадратной матрице заменить все симметричные и равные элементы на нули.Решить с помощью процедур

СРОЧНО! ПОМОГИ! ПОЖАЛУЙСТА!!!!!! №1. В системе счисления с некоторым основанием десятичное число 43 записывается в виде «111». Укажите это

основание

№2. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись десятичного числа 53 оканчивается на 3.

№3. Укажите через запятую в порядке возрастания все числа, не превосходящие 30, запись которых в двоичной системе счисления оканчивается на «101». Числа в ответе указывайте в десятичной системе счисления.

№4. Количество единиц в двоичной записи числа 12, 25 равно…

№5. Для кодирования букв А,Б,В,Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким образом закодировать последовательность символов ГБАВ и перевести результат в шестнадцатеричную систему счисления, то получится…

№6. Как представляется десятичное число 13,5 в двоичной системе счисления?

№7. Как представляется десятичное число 416 в восьмеричной системе счисления?

№8. Как представляется десятичное число 523 в шестнадцатеричной системе счисления?

№9. Вычислите значение суммы 1012 + 118 + 1016. Результат представьте в виде десятичного числа.

№10. Вычислите значение разности двух чисел 1116 – 118. Результат представьте в виде десятичного числа.

Помогите составить алгоритм!

Составьте алгоритм(в паскале\на алгоритмическом языке), в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.

Читайте также

1. Дан массив. Напечатать:

а) Все четные элементы
б) Все элементы, оканчивающиеся нулем.

2. В массиве хранится информация о количестве осадков, выпавших каждый день января. Определить, в какие числа месяца осадков не было.

1. Дан массив. Напечатать:а) Все четные1. Дан массив. Напечатать:

а) Все четные элементы
б) Все элементы, оканчивающиеся нулем.

2. В массиве хранится информация о количестве осадков, выпавших каждый день января. Определить, в какие числа месяца осадков не было.

Паскаль.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Найдите ошибку,ибо выдает он всегда,что спортсмен не проходит,даже если сумма 100,а общее количество 60.!!!

В массиве хранится информация о баллах,
полученных спортсменом-десятиборцем в каждом из десяти видов спорта. Для выхода
в следующий этап соревнований общая сумма баллов должна превысить некоторое
известное значение. Определить вышел ли данный спортсмен в следующий этап
соревнований.



Вы находитесь на странице вопроса "в массиве хранится информация о количестве осадков(целые числа),выпавших за каждый день прошедшей недели.Вывести номера дней,когда осадков не было", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.