Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Напишите программу, которая в последовательности натуральных чисел, оканчивается на 2.

5-9 класс

Программа получает на выходе количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется числа, оканчивающиеся на 2
Количество чисел не превышает 1000. Введённые числа не превышают 30 000
Программа должна ввести одно числа - максимальное число, оканчивающиеся на 2

EsilaImEsMi 04 марта 2014 г., 20:08:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Malooi
04 марта 2014 г., 22:57:12 (10 лет назад)

var
n,i,max,num:integer;
begin
readln(n);

for i:=1 to n do begin 
  readln(num); 
  if (num mod 10=2) and (num > max)
    then max:=num;
end;
writeln(max);
end.

Ответить

Другие вопросы из категории

Три дочери писательницы Дорис Кей - Джуди, Айрис и Линда - тоже очень талантливы. Они приобрели известность в разных видах искусств - пении, балете и

кино. Все они живут в разных городах, поэтому Дорис часто звонит им в Париж, Рим и Чикаго. Известно, что: 1) Джуди живёт не в Париже, а Линда - не в Риме; 2)парижанка не снимается в кино; 3) та, кто живёт в Риме, певица; 4) Линда равнодушна к балету. Где живёт Айрис и какова её профессия?

Паскаль

5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 ( значение a вводится с клавиатуры;b>=10) в) третьи степени всех целых чисел от a до 50 ( значение a вводится с клавиатуры;a<=50); г) все целые числа от a до b ( значения a и b вводятся с клавиатуры;b>=a).

Три сопротивления соединены параллельно. Вычислить общее сопротивление.

Напишите пожалуйста программу для Паскаля

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход

натуральные числа, количество введенных чисел не известно, последовательность чисел заканчивается 0.

Количество чисел не превышает 100. Введенные числа не превышают 30000.

Программа должна вывести одно число: сумму двухзначных чисел, кратных 5.

Люди! Плиииз, помогите! Т,Т

хееееееееелп ми!!!ПАСКАЛЬ, Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, сумма единиц и десятков

кратна 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).



Вы находитесь на странице вопроса "Напишите программу, которая в последовательности натуральных чисел, оканчивается на 2.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.