Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

С клавиатуры вводится произвольное количество чисел N. Определите количество (К) и сумму (S) положительных чисел, оканчивающихся на 6.

5-9 класс

Напишите скрипт пожалуйста

Sanyk997 01 янв. 2015 г., 22:58:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Holmokstar
02 янв. 2015 г., 1:07:30 (9 лет назад)

Var n,k,s:integer;
begin
Writeln ('вводи числа, по окончанию введи 9999');
while n<9999 do
begin
readln (n);
if (n>0) and (n mod 10=6) then
   begin
   inc(k);
   s:=s+n;
   end;
end;
writeln ('кол-во=',k);
writeln ('сумма=',s);
end.

Ответить

Другие вопросы из категории

Решить на языке Питон (в крайнем случае на Паскале) По данным двум натуральным числам A и B (A≤B) выведите все чётные числа на отрезке от A до B. В этой за

даче нельзя использовать инструкцию if.
Пример: Входные данные: 1 10 Выходные данные: 2 4 6 8 10

Определите, что будет напечатано в результате выполнения следующего алгоритма:

Var s,k: integer;
begin
s:= 100
k:=7
repeat
s:= s-k
k:=k+1
Until k>10
writeln( s+k)
end.
Пожалуйста объясните как вывести отсюда результат

Читайте также

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

В ПАСКАЛЕ!№1 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить сколько среди них чисел, кратных 4; №2 С клавиатуры вводятся 10

натуральных двузначных чисел. Определить

среднее арифметическое нечетных чисел;

№3 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить

верно ли, что среди введенных чисел есть число, в котором первая цифра в два раза больше последней.

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые

числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на

вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. Пояснение: цикл while x<>0 do с условием if (x mod 6=0) and (x mod 10=4)



Вы находитесь на странице вопроса "С клавиатуры вводится произвольное количество чисел N. Определите количество (К) и сумму (S) положительных чисел, оканчивающихся на 6.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.