На вход подается строка имеющая вид: ФАМИЛИЯ ИМЯ БАЛЛ1 БАЛЛ 2 ФАМИЛИЯ ИМЯ... Где балл1 и балл2 - баллы предметов. Надо написать программу, показывающую
10-11 класс
|
имена и фамилии ненабравших мин. балла - 30.


Напишу программу на Паскале, если нужна на другом языке, можешь удалять.
program ball ;
var
a, b:string ;
c, d, z: integer ;
begin write ( 'введите фамилию, имя и баллы по двум предметам' ) ; read ('a', 'b', c, d)
z:=c+d
if z<30
then writeln ('a', 'b')
Другие вопросы из категории
файлов. Маска представляет собой последовательность букв, цифр и
прочих допустимых в именах файлов символов, в которых также
могут встречаться следующие символы:
Символ «?» (вопросительный знак) означает ровно один произвольный символ.
Символ «*» (звёздочка) означает любую
последовательность символов произвольной длины, в том числе
«*» может задавать и пустую последовательность.
Определите, какое из указанных имён файлов удовлетворяет маске:
?mur*r.?st
1) mur.lst
2) omurr.sst
3) omur.sts
4) mur.lst
последовательность: 4, 1, 9, 3, 7, 5, из всех чисел которые больше 4 вычесть 3 затем удалить из всей последоательности нечетные числа
Пожалуйста с решением
Читайте также
Вывести на экран - фамилию; - имя; - фамилию и инициалы.
не понимаю, если я даже и начну выводить фамилию, как сделать так. чтобы выделялось только до пробела? ведь фамилии у всех разные. а программа должна быть универсальной для всех фамилий (т.е. фамилия вводится с клавиатуры)
на входе и выводит сумму его цифр.
Я написал первую часть программы (без вывода суммы цифр) :
program sg3;
uses crt;
var i,a,k: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then k:=k+1;
if k=0 then write('Простое')
else writeln('Составное');
readln;
end.
Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль
2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.
элементов массива
Дан массив из N положительных элементов, больших 1
(2<=N<=100).
После каждого элемента вставить его минимальный делитель
больший 1.
Формат входных данных:
На входе подаются в первой строке N - число элементов массива
Вторая строка содержит N чисел - значения элементов массива
Формат выходных данных: Выведите результирующий массив в строку
Пример:
Ввод
5
43 50 76 84 100
Вывод
43 43 50 2 76 2 84 2 100 2
Напиши цифровой фильтр. На вход программе подаётся строка символов. На выходе должны быть только её цифры. Например, если на входе была строка
He110, k177en!
то на выходе должно быть
110177
2. В строке, состоящей из слов, разделённых одним или несколькими пробелами, вывести второе слово. Например, если на вход программе подавалась строка
Меня истина манит сияньем
то на выходе будет
истина
На вход подаётся строка. Вывести часть входной часть строки. Часть строки задаётся номером первого символа и количеством символов.
var
s: string;
n, k, i: integer;
Begin
readLn(s, n, k);
for i := n to n+k-1 do write(s[i]);
End.
2. На вход подаётся предложение на английском языке. Вывести все гласные строки в том порядке, в котором они встречались в строке.
(ключевой фрагмент)
for i := 1 to length(s) do
if s[i] in ['A', 'E', 'I', 'O', 'Y', 'a', 'e', 'i', 'o', 'y']
then write(s[i]);
Варианты программы определения, является ли строка полиндромом
--------------------------------------------------------------
var
s, s1: string;
i: integer;
Begin
readLn(s);
s1 := '';
for i := 1 to length(s) do s1 := s[i] + s1;
write('строка ');
if s1 <> s then write('не ');
writeLn('является полиндромом');
End.
var
s: string;
i, j: integer;
Begin
readLn(s);
i := 1;
j := length(s);
while (i < j) and (s[i] = s[j]) do begin
inc(i);
dec(j);
end;
write('строка ');
if s[i] <> s[j] then write('не ');
writeLn('является полиндромом');
End.